If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Make Download Manager store and display durations of download tasks

RESOLVED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WONTFIX
10 years ago
9 years ago

People

(Reporter: Roman R., Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre

Please make DM store and display how long it has taken to download each file.

Reproducible: Always

Comment 1

10 years ago
see bug 397655 comment 13
No Thanks.  That information is not necessary.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

10 years ago
I disagree with that comment, Jo. And Shawn, that's YOUR opinion. You may not need this information, but I do, and that's why I requested it. For the record, some people think Firefox itself isn't necessary (because IE, Opera, etc. exist).

I download many files often, and I have a need to monitor performance of servers from which I download files and that of my Internet connection. Without this information, I'd be left to time downloading manually, which is stupid because computers are made to do things like that. This information is already available to the Download Manager, so it just needs to persist it and display it.

So, Shawn, if you don't need it, don't use it.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 4

10 years ago
For whom do FF developers develop FF -- themselves or a wide audience with many different interests and preferences? Somewhere on your web pages or in FF 3 itself, it's said that users' opinions matter. So, here I am, a user, telling you what I, a user, need, and your reply to me is that I don't need it? It's wise to speak only for oneself. Say that you YOU don't need this information not that it's unnecessary at all.
As the sub module owner of the component, I'm WONTFIXing this.  If you really want it, you can do it in an addon.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago10 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

10 years ago
Great, more support for those who say FF has to be used with twenty thousand add-ons to make it good.... :(  And I asked for such a simple and basic feature.
I'm just going to point out that we already store the start and end time of a download, so making an addon for this should be fairly trivial.
(Reporter)

Comment 8

10 years ago
That's potentially useful information, but I think that adding displaying another piece of information to the existing code is a much better approach. To populate the list of downloaded files you already have to access the DB and get attributes for tasks. It would probably take a few minutes to add this small but very useful to some enhancement.

Ability to extend an application with add-ons is a great idea, but pushing some basic features to extensions is a hassle to extension developers and users. Obtaining weather or stock information automatically or script debugging should be done by extensions, but displaying how long it took to download a file should be done by the download manager.

Comment 9

10 years ago
I know you are averse to an extension for this, but download statusbar is a really great add-on and it does anything you want it to. I wish this were the default management scheme. It works very well with the one-window idea that tabbing promotes. And, for the record, I do agree with you that more options for things is what fx really needs. 
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.