Last Comment Bug 411037 - SSL error page when built using libxul doesn't have the two buttons for get me out of here/add exception
: SSL error page when built using libxul doesn't have the two buttons for get m...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: Firefox 3 beta3
Assigned To: Alexander Sack
:
Mentors:
Depends on: 486826
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-06 11:59 PST by Raúl Porcel
Modified: 2009-04-04 05:16 PDT (History)
9 users (show)
mconnor: blocking‑firefox3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
explicitly override (2.10 KB, patch)
2008-01-07 03:52 PST, Alexander Sack
mconnor: review+
mconnor: approval1.9+
Details | Diff | Review

Description Raúl Porcel 2008-01-06 11:59:06 PST
The bug is pretty simple, if you build firefox using --with-libxul-sdk=(path of xulrunner) the SSL error page doesn't have the two buttons.

This is with libxul-sdk:
http://dev.gentoo.org/~armin76/ssl1.png
This is without libxul-sdk:
http://dev.gentoo.org/~armin76/ssl.png

The page i'm trying to access is https://bugs.gentoo.org

I believe this is because the error page with the two buttons is included in en-US.jar:locale/en-US/global/netError.dtd . However the en-US.jar manifest doesn't list the global directory.

With the en-US.jar provided without libxul-sdk, the directory is included in the manifest, therefore, the error page is the correct one. With libxul-sdk it defaults to netErrorApp.dtd, which doesn't include the two buttons.
Comment 1 Christopher Aillon (sabbatical, not receiving bugmail) 2008-01-06 12:07:22 PST
Wow, there are supposed to be buttons there!?  I think this affects us, too!  O_o
Comment 2 :Gavin Sharp [email: gavin@gavinsharp.com] 2008-01-06 12:31:28 PST
Sounds like this might be what Neil mentioned in the last paragraph of bug 405862 comment 8.
Comment 3 Jo Hermans 2008-01-06 12:39:06 PST
(In reply to comment #1)
> Wow, there are supposed to be buttons there!?  I think this affects us, too! 
> O_o
> 

The buttons should appear when you click on the "Or you can add an exception…" link.
Comment 4 Alexander Sack 2008-01-07 03:52:34 PST
Created attachment 295751 [details] [diff] [review]
explicitly override
Comment 5 Raúl Porcel 2008-01-07 06:24:42 PST
Works for me with that patch
Comment 6 Mike Connor [:mconnor] 2008-01-07 10:59:34 PST
Comment on attachment 295751 [details] [diff] [review]
explicitly override

r+a=me, good catch
Comment 7 Reed Loden [:reed] (use needinfo?) 2008-01-07 14:30:44 PST
Checking in browser/locales/jar.mn;
/cvsroot/mozilla/browser/locales/jar.mn,v  <--  jar.mn
new revision: 1.74; previous revision: 1.73
done

Note You need to log in before you can comment on or make changes to this bug.