Bidi resolution causes duplication of background images

RESOLVED FIXED in mozilla1.9beta3

Status

()

P3
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: smontagu, Assigned: uriber)

Tracking

({regression, testcase})

Trunk
mozilla1.9beta3
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 295661 [details]
Testcase (reduced from http://bugzilla.wikimedia.org/show_bug.cgi?id=12244)

When an inline element has a background image defined in CSS and contains text with different directionalities, the background image is repeated in each directional run.

This is a regression since Firefox 2. I haven't checked the exact regression date yet, but I strongly suspect that it is a side-effect of bug 299065.
Flags: blocking1.9?
(Assignee)

Comment 1

11 years ago
Yeah, almost certainly 299065. And offhand, it seems like this is going to be very difficult to fix... :-(
Blocks: 299065

Updated

11 years ago
Keywords: regression, testcase
We already handled backgrounds on inlines that split at line breaks, so it should be just a matter of that code handling continuations instead of next-in-flows, i.e. fairly simple. Uri, why do you think it's hard?
(Assignee)

Comment 3

11 years ago
(In reply to comment #2)
> We already handled backgrounds on inlines that split at line breaks,

I didn't know that (and I couldn't be bothered to check...)

> Uri, why do you think it's hard?

Because I didn't know that (and I couldn't be bothered to check...)
Assignee: nobody → uriber
(Assignee)

Comment 4

11 years ago
Created attachment 295976 [details] [diff] [review]
patch
Attachment #295976 - Flags: superreview?(roc)
Attachment #295976 - Flags: review?(roc)
(Assignee)

Updated

11 years ago
Status: NEW → ASSIGNED
Comment on attachment 295976 [details] [diff] [review]
patch

super, thanks!
Attachment #295976 - Flags: superreview?(roc)
Attachment #295976 - Flags: superreview+
Attachment #295976 - Flags: review?(roc)
Attachment #295976 - Flags: review+
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
(Assignee)

Comment 6

11 years ago
Checking in mozilla/layout/base/nsCSSRendering.cpp;
/cvsroot/mozilla/layout/base/nsCSSRendering.cpp,v  <--  nsCSSRendering.cpp
new revision: 3.335; previous revision: 3.334
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11

Updated

11 years ago
Flags: in-testsuite?
(Assignee)

Updated

11 years ago
Depends on: 412093
(Assignee)

Comment 7

11 years ago
This should be covered by the reftest for bug 412093, when we have it.
Flags: in-testsuite? → in-testsuite-

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: layout.bidi → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.