leading tilde is not expanded to $HOME in file:// urls

RESOLVED DUPLICATE of bug 93141

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 93141
10 years ago
10 years ago

People

(Reporter: lvm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.11) Gecko/20071202 SeaMonkey/1.1.7
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.11) Gecko/20071202 SeaMonkey/1.1.7

when I try to open a file in my home directory referenced by a tilde (~/file.html) tilde is stripped from the path, seamonkey tries to open /file.html

Reproducible: Always

Steps to Reproduce:
prerequisites: ~/file.html must exist

1. type "file://~/file.html" in the address field and press enter

Actual Results:  
seamonkey displays an error message in the browser window

File Not Found
The file /file.html cannot be found. Please check the location and try again.



Expected Results:  
~/file.html ($HOME/file.html) should open
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 93141
You need to log in before you can comment on or make changes to this bug.