compressing folders results in heavily fragmented mailbox files

RESOLVED DUPLICATE of bug 172792

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 172792
10 years ago
10 years ago

People

(Reporter: Jan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 2.0.0.9 (20071031) german version

I use 2 IMAP accounts with ~30 folders combined and have some filters to sort the messages.

When I select "compress all folders" (German: "Alle Ordner dieses Kontos komprimieren") from the file menu, this will result in heavy fragmentation of the mailbox files. I just checked a ~150MB mail folder: one disk fragment before compression, ~1200 fragments afterwards. No mailbox ended up in less than some dozen to several hundred fragments.

On a related note (different issue?), the compression does not seem to finish. Disk activity stops after a while, but there is still a message in the bottom left corner: would be something like "checking for new mail" in English. I have not checked this time, but several times I noticed there were temporary files in  the mail folders, although judging from network & disk activity, the checking for new mail & folder compression had finished.

I am not an expert, so please be patient if I should have overlooked something obvious.

Reproducible: Always

Steps to Reproduce:
1.Check fragmentation of mailbox files (I used "Defraggler" which shows fragmentation for individual files). Defragment them if applicable.
2.Start Thunderbird & execute "compress all folders" from the file menu.
3.Check fragmentation again.
Actual Results:  
The mailbox files consisted of anywhere from ~10 to ~1200 fragments.

Expected Results:  
The mailbox files should not be fragmented that heavily (if at all).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 172792
You need to log in before you can comment on or make changes to this bug.