Mingw build error: error: cannot convert `nsAutoString' to `HINSTANCE__*' for argument `1' to `void* LoadImageA

RESOLVED DUPLICATE of bug 411102

Status

()

defect
RESOLVED DUPLICATE of bug 411102
12 years ago
12 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

12 years ago
I'm getting this build error with current mingw debug build.

rive/c/mozilla/mozilla/content/svg/content/src/../../../html/content/src -I/cygd
rive/c/mozilla/mozilla/content/xbl/src -I/cygdrive/c/mozilla/mozilla/gfx/src/the
bes        -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-a
lign -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -
Wno-long-long -pedantic -mms-bitfields -pipe  -DDEBUG -D_DEBUG -DDEBUG_mw -DTRAC
ING -g   -DWINVER=0x501 -D_WIN32_WINNT=0x501 -D_WIN32_IE=0x0500 -DX_DISPLAY_MISS
ING=1 -DMOZILLA_VERSION=\"1.9b3pre\" -DMOZILLA_VERSION_U=1.9b3pre -DHAVE_SNPRINT
F=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DS
TDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DSTDC_
HEADERS=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=
1 -DHAVE_MALLOC_H=1 -DHAVE_LIBM=1 -DNO_X11=1 -DMMAP_MISSES_WRITES=1 -DHAVE_STRER
ROR=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DVA_COPY=va_copy -DHAVE_
VA_COPY=1 -DMOZ_EMBEDDING_LEVEL_DEFAULT=1 -DMOZ_EMBEDDING_LEVEL_BASIC=1 -DMOZ_EM
BEDDING_LEVEL_MINIMAL=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_XUL_APP=1
-DMOZ_DEFAULT_TOOLKIT=\"cairo-windows\" -DMOZ_THEBES=1 -DMOZ_CAIRO_GFX=1 -DMOZ_D
ISTRIBUTION_ID=\"org.mozilla\" -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DMOZ_XPI
NSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_NO_XPCOM_OB
SOLETE=1 -DMOZ_XTF=1 -DMOZ_MATHML=1 -DMOZ_ENABLE_CANVAS=1 -DMOZ_SVG=1 -DMOZ_SVG_
FOREIGNOBJECT=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_PLACES=1 -DMOZ_FEEDS=1 -DMOZ_
STORAGE=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_LOGGING=1 -DHAVE___
CXA_DEMANGLE=1 -DMOZ_DEMANGLE_SYMBOLS=1 -DHAVE__UNWIND_BACKTRACE=1 -DMOZ_USER_DI
R=\"Mozilla\" -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=
1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DMOZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".dll\
" -DJS_THREADSAFE=1 -DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZILLA_LOCALE
_VERSION=\"1.9a1\" -DMOZILLA_REGION_VERSION=\"1.9a1\" -DMOZILLA_SKIN_VERSION=\"1
.8\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT /cygdrive/c/mozilla/mozilla/content/
svg/content/src/nsSVGFilters.cpp
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp: In member function
`virtual nsresult nsSVGComponentTransferFunctionElement::GenerateLookupTable(PRU
int8*)':
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp:2018: warning: compa
rison between signed and unsigned integer expressions
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp:2042: warning: compa
rison between signed and unsigned integer expressions
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp: In member function
`virtual nsresult nsSVGFEImageElement::AfterSetAttr(PRInt32, nsIAtom*, const nsA
String_internal*, PRBool)':
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp:5314: error: cannot
convert `nsAutoString' to `HINSTANCE__*' for argument `1' to `void* LoadImageA(H
INSTANCE__*, const CHAR*, UINT, int, int, UINT)'
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp: In member function
`virtual nsresult nsSVGFEImageElement::BindToTree(nsIDocument*, nsIContent*, nsI
Content*, PRBool)':
c:/mozilla/mozilla/content/svg/content/src/nsSVGFilters.cpp:5338: error: cannot
convert `nsAutoString' to `HINSTANCE__*' for argument `1' to `void* LoadImageA(H
INSTANCE__*, const CHAR*, UINT, int, int, UINT)'
make[7]: *** [nsSVGFilters.o] Error 1
make[7]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox/content/svg/con
tent/src'
make[6]: *** [libs] Error 2
make[6]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox/content/svg/con
tent'
make[5]: *** [libs] Error 2
make[5]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox/content/svg'
make[4]: *** [libs] Error 2
make[4]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox/content'
make[3]: *** [libs_tier_gecko] Error 2
make[3]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox'
make[2]: *** [tier_gecko] Error 2
make[2]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox'
make[1]: *** [alldep] Error 2
make[1]: Leaving directory `/cygdrive/c/mozilla/mozilla/_firefox'
make: *** [alldep] Error 2

C:\mozilla\mozilla>
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411102
You need to log in before you can comment on or make changes to this bug.