Clicking and changing IMAP folders crashes Thunderbird

RESOLVED DUPLICATE of bug 411145

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 411145
10 years ago
10 years ago

People

(Reporter: Jay Moran (jaym/lazvon), Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b3pre) Gecko/2008010615 Firefox/3.0b3pre
Build Identifier: version 3.0a1pre (2008010617) -- CVS checkout and built at that date/time stamp

Inside of Thunderbird I have an IMAP server that has several IMAP folders that I use to sort mail. The actual sorting happens via the Exchange Server side rule. I click in each of the different folders to read different messages. Three times now (since I started using the 3.0a1pre builds (was using 2.0.x.x nightly builds before)) it has crashed when I'm click on different folders to check for new messages. All three times there were no new messages in the folders, so it could be that I am "rapidly" changing folders. I have no altered this behavior since using the 2.x nightly builds.

Reproducible: Sometimes

Steps to Reproduce:
1. Change between IMAP folders (perhaps in a slightly rapid fashion).
Actual Results:  
Thunderbird Crashes/Quits and "Report Crash to Apple" interface pops up.

Expected Results:  
Folder change would happen and I would view contents of the folder.

about:buildconfig (This was from Firefox, but I build Thunderbird with all of the same options below)

Build platform
target
i386-apple-darwin8.11.1

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 4.0.1 (Apple Computer, Inc. build 5367) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -fno-common -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon -pipe
c++ 	gcc version 4.0.1 (Apple Computer, Inc. build 5367) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -isysroot /Developer/SDKs/MacOSX10.4u.sdk -fpascal-strings -fno-common -fshort-wchar -I/Developer/SDKs/MacOSX10.4u.sdk/Developer/Headers/FlatCarbon -pipe

Configure arguments
--enable-application=browser --enable-extensions=default,spellcheck --enable-official-branding --enable-macos-target=10.4 --with-macos-sdk=/Developer/SDKs/MacOSX10.4u.sdk '--enable-optimize=-O3 -ftree-vectorize -fast -march=prescott -mfpmath=sse,387 -fforce-addr -mieee-fp -msse3 -msse2 -msse -mmmx -fsched-spec-load-dangerous -ftree-loop-linear -fivopts' --enable-reorder --enable-strip --enable-static-libs --enable-pthreads --enable-svg --enable-canvas --enable-prebinding --disable-tests --disable-debug --disable-shared --without-system-png --without-system-mng --without-system-nspr --without-system-zlib --without-system-jpeg
(Reporter)

Comment 1

10 years ago
Created attachment 295779 [details]
Apple Crash Report
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk

Comment 2

10 years ago
does it ever happen with mozilla-supplied builds?
(Reporter)

Comment 3

10 years ago
I was hoping to avoid that... BUT you are correct I really should use a supplied nightly build for testing this out. So I've downloaded and installed "version 3.0a1pre (2008010703)" from the nightly build last night... sure enough same problem. That was pretty easy to reproduce actually. Thunderbird reported the crash and I've CC'd what showed up in the window here.

-----
BuildID: 2008010703
CrashTime: 1199725334
InstallTime: 1199725220
ProductName: Thunderbird
StartupTime: 1199725228
URL: 
UserID: a795e27a-979c-234d-93e2-3afc51615c20
Vendor: 
Version: 3.0a1pre

This report also contains information about the state of the application when it crashed.
--------

Comment 4

10 years ago
Can we get the breakpad crash id?
(Reporter)

Comment 5

10 years ago
http://crash-stats.mozilla.com/report/index/6680e96b-bd42-11dc-af92-001a4bd43ed6?date=2008-01-07-17

Sorry about that, didn't know everything wasn't included in what I'd cut and paste from the end user dialog box for the crash reporter.

Comment 6

10 years ago
Thanks, duping to bug 411145 which all needed summary already.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 411145
(Reporter)

Comment 7

10 years ago
You should check out Bug 415601 if you've arrived at this bug from searching. I'm not sure that they truly are the same or not, but the symptoms that I describe here are directly fixed with the (currently) proposed patch in Bug 415601.
You need to log in before you can comment on or make changes to this bug.