Last Comment Bug 411188 - days-from-date of leap year fails
: days-from-date of leap year fails
Status: RESOLVED FIXED
: fixed1.8.1.13
Product: Core Graveyard
Classification: Graveyard
Component: XForms (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 420253 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-07 12:39 PST by aaronr
Modified: 2016-07-15 14:46 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (1.55 KB, application/xhtml+xml)
2008-01-07 12:39 PST, aaronr
no flags Details
patch (2.26 KB, patch)
2008-02-29 17:56 PST, Merle Sterling
aaronr: review+
doronr: review+
Details | Diff | Splinter Review

Description aaronr 2008-01-07 12:39:15 PST
If a user tries to get days-from-date from "2008-02-29" we return NaN instead of 13938.  XSmiles and formsPlayer both return the correct value.
Comment 1 aaronr 2008-01-07 12:39:52 PST
Created attachment 295825 [details]
testcase
Comment 2 Merle Sterling 2008-02-29 17:56:48 PST
Created attachment 306642 [details] [diff] [review]
patch

Calculation of leap years in nsSchemaValidatorUtils::GetMaximumMonthInDayFor is incorrect. Additionally, we don't handle the case where the time string ends with fractional seconds and is not followed by a Z or +/- timezone offset.
Comment 3 aaronr 2008-03-03 10:08:05 PST
*** Bug 420253 has been marked as a duplicate of this bug. ***
Comment 4 aaronr 2008-03-06 09:09:40 PST
checked into trunk and 1.8 branch for msterlin

Note You need to log in before you can comment on or make changes to this bug.