After a successful drop the bookmark menu is not rebuilt until restart

RESOLVED FIXED in Firefox 3 beta3

Status

()

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

Trunk
Firefox 3 beta3
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

11 years ago
See https://bugzilla.mozilla.org/show_bug.cgi?id=405087#c38

The bookmark menu drop target is correct but after a succesfully drop the menu is not rebuilt until browser restart.

this should be a blocker
Flags: blocking-firefox3?
(Assignee)

Comment 1

11 years ago
Created attachment 295921 [details] [diff] [review]
rebuild view on drop

this works fine, the view is forced to rebuild on drop
Attachment #295921 - Flags: review?(mano)
Comment on attachment 295921 [details] [diff] [review]
rebuild view on drop

as i noted on the other bug, itemMoved is expected to take of moving the dom node.
Attachment #295921 - Flags: review?(mano) → review-
itemMoved/itemInserted, depends on the original item placement.
(Assignee)

Comment 4

11 years ago
thnak you, i'll check there
(Assignee)

Comment 5

11 years ago
Created attachment 296053 [details] [diff] [review]
a big problem for a tiny typo
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Attachment #296053 - Flags: review?(mano)
(Assignee)

Updated

11 years ago
Attachment #295921 - Attachment is obsolete: true
Comment on attachment 296053 [details] [diff] [review]
a big problem for a tiny typo

ugh, thanks! r=mano.
Attachment #296053 - Flags: review?(mano) → review+
(Assignee)

Updated

11 years ago
Attachment #296053 - Flags: approval1.9?

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Keywords: checkin-needed
Attachment #296053 - Flags: approval1.9?
mozilla/browser/components/places/content/menu.xm 1.95
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M11
(Assignee)

Updated

11 years ago
Duplicate of this bug: 411476

Comment 9

11 years ago
*** VERIFIED
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.