to prevent flashing (of the autocomplete results) when backspacing in the url bar, attempt to use the previous results

RESOLVED DUPLICATE of bug 424673

Status

()

RESOLVED DUPLICATE of bug 424673
11 years ago
11 years ago

People

(Reporter: moco, Unassigned)

Tracking

({perf})

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

to prevent flashing (of the autocomplete results) when backspacing in the url bar, attempt to use the previous results

unlike when typing an additional character, deleting makes it so the current search is a superstring (not a substring) of the previous search, so we ignore the previous results.

see http://lxr.mozilla.org/seamonkey/source/toolkit/components/places/src/nsNavHistoryAutoComplete.cpp#268

what we could do is take the previous results (which should all match, except for any tag results, which are not partial matches) and use them until our search comes back.

the results might jump around, but this might be better than what we currently do.

note, if the autocomplete algorthim changes (see edward lee's adaptive and word boundary patches), this might not be as straight forward.

this suggestion comes from vlad.
Keywords: perf

Comment 1

11 years ago
There's a patch in bug 424673.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 424673
You need to log in before you can comment on or make changes to this bug.