Plugin management is BROKEN

RESOLVED WONTFIX

Status

Toolkit Graveyard
Plugin Finder Service
--
major
RESOLVED WONTFIX
11 years ago
4 years ago

People

(Reporter: e, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en_GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en_GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

I am telling you that whatever system you use now to assign plugins to mimetypes is badly broken across multiple platforms BREAKING PLUGINS COMPLETELY. This is not a duplicate of "Bug 19118 – Plug-In Manager" as I am not requesting a particular solution.

If I go to youtube and get a broken quicktime logo where a flash animation should be and I can't fix it without admin privileges...

This is not a feature request. I'm asking for you to fix plugin handling.

Reproducible: Sometimes

Steps to Reproduce:
1. Install firefox
2. Install the standard range of plugins from https://addons.mozilla.org/en-US/firefox/browse/type:7
3. Visit http://youtube.com
Actual Results:  
Plugins are installed but don't work in Firfox because Plugin management is broken.

Expected Results:  
Watch movies with flash player

A bug that effectively disables plugins completely is breaking a major feature.
Could be an issue similar to Bug 324555 or Bug 317047. 
either do not install a broken plugin like quicktime which claims to play flash but fails in many cases or configure quicktime to not play flash. 
You can cleary see in "about:plugins" (as URl without "") that it reports that it can play flash files. 
BTW: You can configure quicktime somewhere in the windows system control.

There is nothing wrong in the Plugin management and i really don't know why you don't ask apple why they don't fix the quicktime plugin.

-> invalid
 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
That's just ridiculous. 

You can say whatever you please. You can mark bugs invalid as much as you please.
You will continue to have people report this bug because its a major feature and it's so flaky as to be broken as often as not.

Who is launching the wrong plugin? Firefox is launching the wrong plugin.
You are saying "Our plugin handling works if you don't install the plugins"

It's BROKEN and it's not just quicktime. The common feature is Firefox.
I happen to REQUIRE flash, quicktime and adobe reader.
You need to get in touch with a production environment.

I gave one example of the many and numerous ways that the current fragile auto selection system fails to get it right. At first it greyed out the boxes needed to fix mimetype assignment, assuming that FIREFOX's automatic assignment is infallible. Now that dialog seems to have disappeared completely...

Of couse the quicktime plugin lists its capabilities. It plays flash video.
Firefox's plugin to mimetype system is fallible. It is very fallible indeed.
It is Firefox's failure.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
The basic problem is with quicktime. You have configured (or it has configured itself) to play flash movies. Firefox is looking at it's plugins, spots one that claims to play flash and tells it to play the flash. Quicktime then fails.

You can simply tell quicktime to not handle flash and the problem will go away.

http://kb.mozillazine.org/Flash#Quicktime_plugin_takes_over_Flash

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 19118
(Reporter)

Comment 5

11 years ago
Our CAD system requires Quicktime.
We also require flash.
I am pushing for adoption of Firefox in our office.
This kind of **** rubbish makes you hard to sell.
The statu quo works.
No-one is suggesting that you can't have both installed, only that you follow the simple instructions in the website given to stop Quicktime from claiming that it should play flash files.
As I told you already in comment#2, the problem is that Quicktime is broken.
If you need qt you can configure it that it should not play flash and your problem is gone.
If you are unhappy why you have to do this, then you have to ask apple (and not us) why the qt plugin itself wants to play flash files but fails to do.

Firefox itself just looks for a plugin that can play flash, depending which one is first found (qt or macromedia flash) you will get the problem.

verified dupe

Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

11 years ago
I've configured quicktime to not play flash.
Preferences:Content:Manage shows that Shockwave Flash handles flash animations...
I go to the quicktime dontrol panel dialog & flash files are unchecked.
every other program on the system knows I want flash to run flash files.

except for Firefox, because Firefox's handling of mimetypes is broken.

Firefox finds quictime first regardless. It's broken.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
You probably mistakenly changes quicktimes file handling rather than it's mimetype settings. Please re-read the link carefully.

Regardless this bug is still a duplicate of bug 19118 since what you are asking for is to be able to choose which plugin Firefox plays something with when it has multiple installed plugins that can handle that content. Please do not reopen this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 19118
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

11 years ago
In Firefox,
Preferences:Content:Manage says that shockwave flash will handle flash media but,
Firefox launches quicktime.

Say what you like. That's rubbish.

iexplore launches flash.
(Reporter)

Comment 11

11 years ago
(In reply to comment #9)

> Regardless this bug is still a duplicate of bug 19118 since what you are asking
> for is to be able to choose which plugin Firefox plays something with when it
> has multiple installed plugins that can handle that content.

no

In Firefox:Preferences:Content:Manage Firefox says that shockwave flash will handle flash media but Firefox launches quicktime. That's broken.
This is clearly a bug with the CURRENT dialog, wouldn't you agree?
I have clearly stated that this bug is about how broken the current system is.

If you wish to ignore that because you don't like one possible solution...

The point to comments relating to bug 19118 is that if the auto/default plugin selections were consistent from one page to the next & vaguely resembled accepted norms from firefox's plugin download page, there wouldn't be an endless stream of people asking for a fixed choice.

> You probably mistakenly changes quicktimes file handling rather than it's
> mimetype settings. Please re-read the link carefully.

Yes I saw what you meant RE:Quicktime control panel, under browser plugin not mimetype/filetype. Oops

FYI: There were no options under browser plugin relating to any flash file formats. Cheers for the suggestion though. I'll try the deleting config & dll files bit from the HOWTO on someone else's production box though if you don't mind. It's not like it's hard to find boxes with the problem. Just need to find a firefox install in an ArchiCAD office really.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
>In Firefox:Preferences:Content:Manage Firefox says that shockwave flash will
>handle flash media but Firefox launches quicktime. That's broken.
>This is clearly a bug with the CURRENT dialog, wouldn't you agree?

It could be but that is not this bug report, you have to write a new one that the plugin list shows the wrong one in that case you have two plugins with the same mimetype. But you can not change the used plugin there, we have bug 19118 for really managing it.

This is a dupe but because i don't want to spam i will just mark it invalid because the fault itself that you describe is Apples quicktime fault.
you can reopen this again if you want but that doesn't make this bug valid.



Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 13

11 years ago
(In reply to comment #12)
> It could be but that is not this bug report, you have to write a new one that
> the plugin list shows the wrong one in that case you have two plugins with the
> same mimetype. But you can not change the used plugin there, we have bug 19118
> for really managing it.

Bug 19118  isn't managing anything. It's marked feature request, not bug.
They are discussing appropriate dialogues for a feature that doesn't exist.

> This is a dupe but because i don't want to spam i will just mark it invalid
> because the fault itself that you describe is Apples quicktime fault.
> you can reopen this again if you want but that doesn't make this bug valid.

When Firefox screws up other plugins, who's fault is that?
You can mark this invalid if it cleans up your inbox.
It doesn't make plugin handling any less of a broken joke in Firefox.
Resolution: INVALID → WONTFIX
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

4 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.