Last Comment Bug 411352 - Update Book of Mozilla passage (about:mozilla)
: Update Book of Mozilla passage (about:mozilla)
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9beta3
Assigned To: Mike Beltzner [:beltzner, not reading bugmail]
:
:
Mentors:
Depends on: 813377
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-08 14:57 PST by Mike Beltzner [:beltzner, not reading bugmail]
Modified: 2013-08-11 15:01 PDT (History)
26 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
First pass (2.61 KB, patch)
2008-01-09 08:12 PST, Johnathan Nightingale [:johnath]
mbeltzner: review+
mbeltzner: ui‑review+
mconnor: approval1.9+
Details | Diff | Splinter Review
Screencap of First pass (147.10 KB, image/png)
2008-01-09 08:27 PST, Johnathan Nightingale [:johnath]
no flags Details
removing .f class, slight change to text (2.75 KB, patch)
2008-01-10 11:33 PST, Mike Beltzner [:beltzner, not reading bugmail]
gavin.sharp: review+
mconnor: approval1.9+
Details | Diff | Splinter Review

Description Mike Beltzner [:beltzner, not reading bugmail] 2008-01-08 14:57:46 PST
http://en.wikipedia.org/wiki/The_Book_of_Mozilla

The last update to the Book of Mozilla in our products was around the generation of the Phoenix project, and in its current form it speaks of the closure of AOL's Netscape division and the foundation of the Mozilla Project. Mozilla has come a long way since then, making huge gains in market share, relevance, and in developing its mission.

For Gecko 1.9, I'm proposing we update the Book of Mozilla passage (for the first time in 5 years) to refer to the support that Firefox received, and to speak towards the future of the Mozilla Manifesto. This passage would also (for the first time ever) link off to the Manifesto as well as the about:mozilla newsletter.

The proposed text is:

As Mammon slept, the beast reborn spread over the earth and its numbers grew legion. They spoke forth the Times and sacrificed crops unto the fire. They held the cunning of foxes, building a new world in their own image as promised by the sacred words, and teaching that world unto their children. And Mammon awoke, and lo! it was naught but a follower.

-- from the Book of Mozilla, 11:9, (10th Edition)

this text references the following events:

 - the lull in development of MSIE
 - Spread Firefox
 - the New York Times ad taken out by Firefox supporters
 - the crop circle made by Firefox supporters
 - the name "Firefox"
 - the development of a new, interactive Web (aka: Web 2.0)
 - the Mozilla Manifesto
 - the about:mozilla newsletter
 - the change of MSIE from technology innovator to follower

I'm also proposing that "sacred words" link to the Mozilla Manifesto, and "teaching that world" link to about:mozilla.

I'll put together a patch with formatting.
Comment 1 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-08 14:59:51 PST
Mozilla Manifesto here: http://www.mozilla.org/about/mozilla-manifesto.html
about:mozilla here: http://wiki.mozilla.org/About:mozilla

Forgot to mention that 11:9 is November 9th, the release date of Firefox 1.0. Other potential verse numbers are 10:12 (launch of SpreadFirefox) and maybe one of the download milestone dates. The "10th Edition" refers to the 10th anniversary of the source code release.
Comment 2 Wolf [:wolf] 2008-01-08 15:37:17 PST
The text sounds good... Though I think you lose a bit by linkifying portions of the text. particularly multiple links. (the manifesto alone, you can probably do without making it look like a blog post.)

11:9 makes much more sense than 10:12 (SFX's launch date isn't that significant by comparision.)
Comment 3 Justin Dolske [:Dolske] 2008-01-08 15:47:10 PST
The links could be styled to look like normal text (perhaps a slightly bigger font, as are some words in the current about:mozilla). I suppose that would sort of make them easter eggs with the easter egg...
Comment 4 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-09 08:07:52 PST
Johnath is working up a patch, actually ... he and I modified the wording a bit again.
Comment 5 Johnathan Nightingale [:johnath] 2008-01-09 08:12:13 PST
Created attachment 296149 [details] [diff] [review]
First pass

This patch is: beltzner's text + dolske's approach to "easter egg links" (good call!) + beltzner's over the shoulder tweaks.

What do people think?
Comment 6 Johnathan Nightingale [:johnath] 2008-01-09 08:27:19 PST
Created attachment 296152 [details]
Screencap of First pass

My text looks fuzzier in this screencap than I remember - might be monitor issues.  In any event, I didn't change the font styling.
Comment 7 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-09 09:25:35 PST
Comment on attachment 296149 [details] [diff] [review]
First pass

r+ui-r=beltzner
Comment 8 Mike Connor [:mconnor] 2008-01-09 09:29:41 PST
Comment on attachment 296149 [details] [diff] [review]
First pass

woo!
Comment 9 Gervase Markham [:gerv] 2008-01-09 12:58:09 PST
Looks good.

Is the NYT ad reference a bit Americentric, in contrast to all the other events? Perhaps we could just change "Times" to "times" or "spoke forth the Times" to "spoke the times"; that way the reference is still there, but a little more hidden.

Don't forget to patch http://www.mozilla.org/book/.

Gerv
Comment 10 Johnathan Nightingale [:johnath] 2008-01-09 13:07:28 PST
Checking in toolkit/locales/en-US/chrome/global/mozilla.dtd;
/cvsroot/mozilla/toolkit/locales/en-US/chrome/global/mozilla.dtd,v  <--  mozilla.dtd
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/content/mozilla.xhtml;
/cvsroot/mozilla/toolkit/content/mozilla.xhtml,v  <--  mozilla.xhtml
new revision: 1.5; previous revision: 1.4
done


Haven't patched /book/ yet though, so leaving this bug active and assigning to beltzner.
Comment 11 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-09 13:35:37 PST
Gerv: you think I should patch /book/ now, or wait until we release Firefox 3? I was expecting the latter, but don't know what's de rigeur here.

And as a Canadian, I'm pretty sure I wasn't being Americacentric when referring to the NYT ad. The goal was to highlight some of the bigger ticket things that were done entirely by "the beast's" faithful, and the NYT ad is such an item.
Comment 12 Jeff Walden [:Waldo] (remove +bmo to email) 2008-01-09 14:14:19 PST
This file hasn't been edited more than once in its history (spread across an XML and an HTML version, over a single day), so I'd say do the simplest thing and just edit now -- why bother having to remember when 3 is released?


Gotta say, I like this!  A couple nits while I'm commenting here, for thought if not for action:


"And they spoke forth the Times"

Esoteric phrasing is the name of the game here, but I am unable to make my brain agree that it conveys the intended meaning, even with generous interpretations of the definitions for "forth" at <http://www.answers.com/forth&r=67>.


"And they built a new world in their own image"

I like promoting cooperative collaboration (my interpretation, it's open for others), but this is a little bit much if you ask me.  :-)  Also, while we might be able to claim some credit for the explosion of Web 2.0, I for one wouldn't want to claim credit for something anointed with such a hideous buzzword.  :-P


"When Mammon awoke, lo! it was <em>naught</em> but a follower."

I liked the "And" here in the initial phrasing.  We already have enough sentences starting with "And"; I'd remove "When" and insert an "and" before "lo!":

"Mammon awoke, and lo! it was <em>naught</em> but a follower."


Last, the CSS for the "f" class could be removed from mozilla.xhtml.
Comment 13 Daniel Veditz [:dveditz] 2008-01-09 15:23:39 PST
I guess it's a bit late, but it might be cool to link "sacrified crops" to

http://maps.google.com/?ie=UTF8&om=1&t=h&ll=45.123785,-123.113962&spn=0.00567,0.016909&z=17

Comment 14 Gervase Markham [:gerv] 2008-01-09 15:33:49 PST
Let's not overdo it. The Google imagery isn't under our control, after all. Next pass they have, it'll probably go away. Remember the Fishcam?

Gerv
Comment 15 Zibi Braniecki [:gandalf][:zibi] 2008-01-10 11:16:37 PST
guys, you're cruel to localizers. :)

btw. I'm not sure if a direct reference to wiki.mozilla.org is a good idea. It somehow de-magifies (or however I should write it in english ;)) the whole idea. With those links it feels less mythological, much more realistic, down to ground atmosphere. I believe we're lowering the "Wow! I found something weird there, maybe abandoned for years in the sources, let's try to decrypt it and lurk for more" effect to "Oh, they're having fun".
Comment 16 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-10 11:33:34 PST
Created attachment 296377 [details] [diff] [review]
removing .f class, slight change to text

Taking some (but not all!) of Waldo's comments into account.
Comment 17 Mike Beltzner [:beltzner, not reading bugmail] 2008-01-10 12:00:48 PST
Checked in /book/index.html v1.2 at www.mozilla.org to match.
Comment 18 Reed Loden [:reed] (use needinfo?) 2008-01-10 12:31:56 PST
Checking in toolkit/content/mozilla.xhtml;
/cvsroot/mozilla/toolkit/content/mozilla.xhtml,v  <--  mozilla.xhtml
new revision: 1.6; previous revision: 1.5
done
Checking in toolkit/locales/en-US/chrome/global/mozilla.dtd;
/cvsroot/mozilla/toolkit/locales/en-US/chrome/global/mozilla.dtd,v  <--  mozilla.dtd
new revision: 1.4; previous revision: 1.3
done
Comment 19 Johnathan Nightingale [:johnath] 2008-01-10 12:42:52 PST
Ah poop, reed.  I was gonna check that in with a credit for beltzner, since he WROTE the text, and ought to get a credit somewhere.
Comment 20 Johnathan Nightingale [:johnath] 2008-01-10 13:45:49 PST
(In reply to comment #19)
> Ah poop, reed.  I was gonna check that in with a credit for beltzner, since he
> WROTE the text, and ought to get a credit somewhere.

Done.

Checking in toolkit/content/mozilla.xhtml;
/cvsroot/mozilla/toolkit/content/mozilla.xhtml,v  <--  mozilla.xhtml
new revision: 1.7; previous revision: 1.6
done

Note You need to log in before you can comment on or make changes to this bug.