Allow wildcard filter in "index of " type page eg. file://///host/sharename/file*

RESOLVED WONTFIX

Status

()

Core
Networking: File
--
enhancement
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: Scott R, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

This request is to enhance Firefox to support URI in the form of "file://///host/sharename/file*" where wild card characters are recognized to filter the directory viewing pages built in a Firefox window.

Reproducible: Always

Steps to Reproduce:
1.Create a shared directory "sharename", place several files in "sharename"
2.Enter URL "file://///host/sharename/file*" 
Actual Results:  
Firefox displays "index of file://///host/sharename/" page. It looks like "file*" is stripped and ignored. Opera 7.x or higher would display "index of file://///host/sharename/file* and only files matching the wild card characters in the URI.

Expected Results:  
The behavior is not currently supported.

As an enhancement it would be useful if Firefox adopted the Opera 7.x or higher "index of file://///host/sharename/file*" behavior of only files matching the wild card characters in URI being shown. This only applies to file resources indicators. This would be useful so bookmarked "file://///host/sharename/file*" would give quick access to a selection of files in the browser window.
Component: File Handling → Networking: File
Product: Firefox → Core
QA Contact: file.handling → networking.file
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.