Logitech mouse back button causes find window to open

RESOLVED DUPLICATE of bug 259450

Status

()

Firefox
Shell Integration
--
minor
RESOLVED DUPLICATE of bug 259450
10 years ago
9 years ago

People

(Reporter: tomte, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010104 Minefield/3.0b3pre

I am using logitech latest wave keyboard and mouse, mouse have back button. when pressed find window will appear at the bottom of window with "♦" inside. some times page will go back, some time only producing ♦ in find field. I couldn't locate any specific situation when it happens. some times field just adds ♦ for each press on back button

Reproducible: Sometimes

Steps to Reproduce:
1.navigate to some page so there is at least one page in history
2.push back button
Actual Results:  
find field will appear with ♦ character in it. 

Expected Results:  
go back 1 in history

Comment 1

10 years ago
I'm having the same problem and symptoms. If I have more than 2 windows open, each with multiple tabs, then the back button fuction on my mouse ceases to function. Only when I reboot am I able to restore back button functionality.

Comment 2

10 years ago
I'm having the same problem and symptoms. If I have more than 2 windows open, each with multiple tabs, then the back button fuction on my mouse ceases to function. Only when I reboot am I able to restore back button functionality.

Comment 3

10 years ago
Please try to find a fix. It's been driving me crazy for almost a year on an otherwise excellent browser-best in the industry!
Duplicate of this bug: 471454

Comment 5

9 years ago
This Bug happens in Fx 2.0 - latest Fx 3.1 nightly 20090304 (Trunk not tested).
Very probably a Bug in Logitech Setpoint driver - back and forward buttons are functional with build-in Microsoft drivers on same machine.

Logitech says:
"Cause: Mozilla Firefox uses non-standard Internet navigation commands. As a result, the Forward and Back buttons on all Logitech mice using SetPoint software mouse do not work in Mozilla Firefox. ...
Solution: The current version of Logitech SetPoint resolves this issue."

http://logitech-en-amr.custhelp.com/cgi-bin/logitech_en_amr.cfg/php/enduser/std_adp.php?p_faqid=3087

This is NOT correct, Bug still happens with very latest Setpoint 4.72

Before resolving this as invalid (it's probably no Fx Bug), someone from Mozilla should try to contact Logitech about this long-standing issue, and/or mention it in Release notes Troubleshooting/Known Issues.

Workaround:
   1. Right click on the Logitech Logo Icon in the System Tray and select "Mouse and Keyboard Settings". 
   2. Click on the "My Mouse" tab; your pointing device should be shown.  If you have more that one mouse connected, select the mouse you wish to program by clicking on the "Select Mouse" drop down menu.
   3. Click on the Forward button under the "Select Button" menu.
   4. Click on the bullet next to the "Keystroke Assignment" in the "Select Task" menu; this will open a "Specify Keystroke" field.
   5. Click your mouse cursor on this field and a flashing text cursor should appear.
   6. Press the ALT key and the right arrow key at the same time so the Keystroke field reads "ALT+right arrow".
   7. Click the "Apply" button to save your changes.
   8. Repeat steps 3-6 for the Back button, except press the ALT key and the left arrow at the same time so the Keystroke field reads "ALT+left arrow".
   9. Click the "Apply" button to save your changes.
  10. Click on the "OK" button to close the SetPoint software.
Source: Knowledge Base article 2178:
http://logitech-en-amr.custhelp.com/cgi-bin/logitech_en_amr.cfg/php/enduser/std_adp.php?p_faqid=2178

Comment 6

9 years ago
duplicate of Bug 259450
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 259450
You need to log in before you can comment on or make changes to this bug.