Closed Bug 41150 Opened 22 years ago Closed 21 years ago

bcc Information Revealed if Msg Forwarded from Sent Folder

Categories

(MailNews Core :: Composition, defect, P2)

x86
Windows 95
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: sol, Assigned: bugzilla)

Details

(Whiteboard: [nsbeta1+] Fix in hand)

Attachments

(1 file)

If you forward a message from your "Sent" folder that contains bcc addressees, 
the bcc information is included in the forwarded message. This information 
should *not* be included in the forwarded message.

The bcc information is included if you "forward inline" or "foward quoted". The 
bcc information is not included if you "foward as attachment".

Build ID - 2000-05-31-08 on WinNT

Steps to reproduce:

1. Launch Seamonkey

2. Start Mail (Tasks | Mail) and supply password when requested.

3. Compose a message and include yourself as a "bcc" in the message

4. Send the message

5. Get messages and read the message you sent in step #4 in your "Inbox"

Note: The bcc information included in step #3 does not appear in the message

6. Open your "Sent" folder and select the message you sent in step #4

Note: The bcc information included in step #3 *does* appear in the message - 
this is valuable information to have in the Sent folder. (It's not a bug!)

7. Make sure that your preferences are set to forward messages either as 
"forward inline" or "foward quoted", and *not* "forward as attachment (Edit | 
Preferences ... | Composing Messages | Forward messages: "Quoted" or "Inline").

8. Forward the message from your "Sent" folder to yourself.

9. Get messages and select the message you forwarded to yourself in step #8.

Expected result: The message you originally sent in step #4 is forwarded, but 
does *not* contain the bcc information you included in step #3

Actual result: The message you sent in step #4 is forwarded and includes the bcc 
information you included in step #3
Actually, this is probably me. 

- rhp
Status: NEW → ASSIGNED
Target Milestone: --- → M19
QA Contact: lchiang → esther
-change qa contact
QA Contact: esther → sheelar
Adding keyword 
Keywords: mail4
Keywords: nsbeta1
Priority: P3 → P2
Whiteboard: [nsbeta1+]
Target Milestone: --- → mozilla0.9
marking nsbeta1+ and moving to mozilla0.9
> The bcc information is included if you "forward inline" or "foward quoted". The 
> bcc information is not included if you "foward as attachment".

Duh! That#S exactly the wrong way around: It should be hidded, if possible (i.e.
for inline and quoted). Forward As Attachment must keep the mail as-is,
on-the-wire, without *any* change.
Target Milestone: mozilla0.9 → mozilla0.9.1
I have a fix for not showing BCC when forwarding inline. I don't want to add it
back when forwarding as attachment despite we should not alter the message.
Revealing BCC recipients could have very bad consequence especially when the
sender cannot realize that!
Attached patch Proposed fixSplinter Review
QA: they is 3 different ways to display headers when forwarding inline a message
depending of the value of the pref mail.show_headers which could be 0, 1 or 2.
Please test all 3 cases. Thanks
Whiteboard: [nsbeta1+] → [nsbeta1+] Fix in hand
r=varada
sr=bienvenu, but instead of commenting out the offending lines, can you just
remove them and add a comment to the effect that we don't want to forward bcc
headers?
OK, I will...
Fixed and checked in
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
verified on the following builds
2001-04-04-12 win98
2001-04-04-08 mac
2001-04-04-14 linux
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.