Create on-line test cases for QA of content/connection-related UI issues, to be used by l10n teams

RESOLVED WONTFIX

Status

Camino Graveyard
Product Site
RESOLVED WONTFIX
11 years ago
5 years ago

People

(Reporter: Marcello Testi, Unassigned)

Tracking

({helpwanted})

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; it; rv:1.8.1.11) Gecko/20071207 Camino/1.6a1 (like Firefox/2.0.0.11)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; it; rv:1.8.1.11) Gecko/20071207 Camino/1.6a1 (like Firefox/2.0.0.11)

Some of the localizable dialogs and information provided by Camino depend on content (Javascript alerts) or connections (various SSL combinations, connection errors...). That means that checking the quality of l10n can't be limited to walk through all menu items, toolbar buttons and pref panes. In order to build a reliable L10n QA checklist, we need to build a set of on-line test cases to be used by l10n teams. 

The expected outcome of this bug is a 2 steps process:
1. Collect all kinds of test cases needed
2. Build test cases
I don't know if cb.o website can be the platform for such application, but I hope so.
I think to solve this we need help from a good web developer who knows how to handle network connections and set up reliable simulations of errors.
We also need a server with SSL capabilities.

Reproducible: Always
(Reporter)

Updated

11 years ago
Summary: Create on-line test cases for QA of content/connection-related issues, to be used by l10n teams → Create on-line test cases for QA of content/connection-related UI issues, to be used by l10n teams
At the very least, we can have a page on the wiki that points to example sites (like the "Organization of Black Helicopters" page for some of the cert sheets).
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> At the very least, we can have a page on the wiki that points to example sites
> (like the "Organization of Black Helicopters" page for some of the cert
> sheets).

This is something I was thinking about for a while, but the problem is that external sites may change without notice: the one with an invalid certificate could get a valid one, one site could stop using JS and so on. The features we're checking against are mostly transparent to the user, so a non experienced reviewer might just write off the list a site that doesn't trigger an expected dialog or triggers a different one.

Comment 3

9 years ago
This isn't something I'd be working on.
Assignee: samuel.sidler+old → nobody
(In reply to comment #1)
> At the very least, we can have a page on the wiki that points to example sites
> (like the "Organization of Black Helicopters" page for some of the cert
> sheets).

There's some links in http://wiki.caminobrowser.org/QA:Release_Testing:l10n for testcases I've been using.  

Unfortunately, as Marcello notes in comment 2, the features that need this sort the most (SSL, etc.) are the ones that require a lot of infrastructure and special configurations, but we could probably get some stable testcases set up for domain not found error page and at least a "cert doesn't match" with some existing subdomains on cbo.  E.g., https://preview.caminobrowser.org/ will throw a cert error, and http://test.caminobrowser.org/ will throw a no-such-domain error.

If someone will do 1 and 2 from comment 0, I'll look at the list and see what they require, prod Sam to get a subdomain created for the ones cbo can handle, and then put them online.  But, uh, helpwanted.
Keywords: helpwanted
I wonder if we can use Mochitest for some of this?  http://wiki.caminobrowser.org/Development:Testing_arbitrary_scenarios_with_Mochitest

Surely there have got to be some tests for some of these things already, and I know Ted added some SSL support (bug 426867).  The only bad thing is that Mochitest isn't built by default in Camino builds (you need --enable-tests), and then once it's built, it has a lot of hard-coded path expectations for where stuff is located that would make it hard to package and distribute for l10n to use.

Something for someone to look into at some point, though (say, after !clone is implemented :P ).

Comment 8

5 years ago
Given the current state of the Camino project, we won't be fixing these website bugs. Mass changing our Product Site bugs (search on "camino-website-bugs").

RESOLVED -> WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.