Closed Bug 411505 Opened 13 years ago Closed 13 years ago

software update nightly builds keep not installing themselves in minefield and thunderbird

Categories

(Toolkit :: Application Update, defect, P1)

x86
Windows XP
defect

Tracking

()

VERIFIED FIXED
mozilla1.9beta3

People

(Reporter: fpiera, Assigned: benjamin)

References

Details

Attachments

(3 files, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010805 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008010805 Minefield/3.0b3pre

The problem was reported in bug 410485 and 411056 which was considered a duplicate of the first mentioned one and Nick Thomas has asked to report as new bug.  When nightly buids are downloaded upon checking for updates, and asked to be installed, actually they are are not installed and the update notice keeps alive asking to download the update.  It has happened since the nightly update of 20080101 and keeps happening in both Minefield and Thunderbird nightly updates of 20080108  The only way to update is to download the full updates from the ftp of Mozilla

Reproducible: Always

Steps to Reproduce:
1.Check for updates
2.Download nightly updates with update window saying that download was correct
3.tap button for installation of update
4.Firefox and Thunderbird disappear and then are reloaded inmediatly without installing the update
5.The updatge notice window appears asking for downloading the update again
Actual Results:  
Updates are not installed

Expected Results:  
updates being installed
Version: unspecified → Trunk
On IRC, this was updating from 2008010805 which has the fix for 410485 and 410610.

The app was installed to C:\Archivos de programa\Mozilla Firefox-Trunk\

Windows XP Spanish

He says that there is no update.log... in that case, I'll need a file monitor log from Process Monitor: http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
Attached file Filemon Log (obsolete) —
I'm attaching filemon log, but just looking at it, you can see that the problem is ó in "c:\Documents and Settings\user\Configuración Local\...".
Creating a folder named Configuraci and copying update.mar makes update work again for both firefox and thunderbird.
Fernando, since your mail is from Spain, I'm guessing you have that ó too
Attached file smaller log
Cleaning-up the log, you can see in line 1685 what I was talking about in the previous comment
Attachment #296166 - Attachment is obsolete: true
Assignee: nobody → benjamin
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3+
Priority: -- → P1
Yes Pablo, I am in Spain and I have that configuration, but the name of the folder you say to be created is not clear to me nor which is the parent directory folder neither where I can find the file "update.mar"
Yes Pablo, I am in Spain and I have that configuration, but the name of the folder you say to be created is not clear to me nor which is the parent directory folder neither where I can find the file "update.mar"
I can confirm this behavior on swedish windows xp as well. Path is C:\Documents and Settings\Username\Lokala inställningar\Application Data\... If I install the nightly from 20071231 it updates once to the latest available nightly and then it repeatedly fails again. Manual update using .mar-file from folder c:\program\minefield-update works fine.
It is not related to windows XP, since vista is affacted also. I also have a special character in my Application Data path (c:\Users\Michaël Arnauts\...)
I have observed that the update downloaded files (short and long) do not have extension of any kind and the windows OS (XP in my case) recognises the update file as a report on access format which of course cannot be opened directly.  This happens both with the Minefield and the Thunderbird updates
auditing is hard :-(
Attachment #297019 - Flags: review?(ted.mielczarek)
Just in case it helps I have observed that the complete updates downloaded using the check for updates tool of both thunderbird and firefox is a file about 2 megabytes bigger than the nightly updates download directly from the ftp directory.
I have checked the update-files for firefox (ftp download vs check for updates) and mine are identical. Did a filecompare and no differences reported. Both updates apply without issues if installed manually from a path without special characters.
Attachment #297019 - Flags: review?(ted.mielczarek) → review+
Fixed on trunk, yay.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M11
I know this was supposed to be fixed, but it's still not working for me :(
updating from
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011910 Firefox/3.0b3pre ID:2008011904
to
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011910 Firefox/3.0b3pre ID:2008011910 (Respin)
had to be done manually as if nothing had changed.
This bug is not fixed nor resolved as with nightly update 20070119 in both Minefield (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011910 Minefield/3.0b3pre) and thunderbird (version 3.0a1pre (2008011903) the problem persists and the update has to done manually
Verified the patch is in the 20080119 nightlies (by bonsai), so reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Two more calls, one of which was probably breaking existing users.  I created a user named "Ramón" and stepped through the code.  With this patch every argument to the updater looks like it survives the UTF-8 -> UTF-16 translation properly.
Attachment #298335 - Flags: review?(benjamin)
Comment on attachment 298335 [details] [diff] [review]
fixup 2 more calls

Ted, I'll have a new patch for you in the morning: this is insufficient for one more reason having to do with the chdir() call below.
Attachment #298335 - Flags: review?(benjamin) → review-
I don't see what you're referring to.  The Windows codepath there uses _wchdir.
Comment on attachment 298335 [details] [diff] [review]
fixup 2 more calls

Huh, I don't either... I had a WIP patch which I thought I had to change one other thing, but apparently I was mistaken.
Attachment #298335 - Flags: review- → review+
Checked in.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Reporter, please verify if this fix is working for you now.  if so, you can mark it verified with the build number included.   thanks.
It is working well with both firefox and thunderbird.  Present version is:Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008020504 Minefield/3.0b4pre
I am using windows XP SP2
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.