"Open All in Tabs" Does Not Work in Places (FF 3.0b2)

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: bliz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b2) Gecko/2007121014 Firefox/3.0b2

Using Open All in Tabs (from right click menu) does not work at all in Places for Firefox 3.0b2. Instead of opening all the tabs from bookmarks in a various folder of any size, only one, blank tab is opened alongside any currently opened tabs.

Reproducible: Always

Steps to Reproduce:
1. Click "Show All Bookmarks" or otherwise open Places
2. Select any folder with bookmarks, be it the toolbar or within the Bookmarks Menu
3. Right click to find the option to open all bookmarks in tabs.

Actual Results:  
Notice how only an empty, untitled tab is launched. If "Open All in Tabs" was selected from the Bookmark Toolbar folder, then the launched empty tab replaces the currently open tab. If any folder of bookmarks is selected, then the launched empty tab is placed alongside currently opened tabs.

Expected Results:  
I would expect all the tabs to be opened alongside currently opened tabs. Otherwise, at least prompt to replace open tabs with the new ones that are supposed to be opened. Right now, none of the "Open All in Tabs" are opened from Places.
(Reporter)

Updated

11 years ago
Summary: "Open All in Tabs" Does Not Work in Places → "Open All in Tabs" Does Not Work in Places (FF 3.0b2)

Comment 1

11 years ago
this works for me on Mac.

you're mention of overwriting existing tabs as opposed to appending new tabs is covered in other bugs.
WFM as well.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

11 years ago
I still can't get it to work. Perhaps a bad install somehow? I'm not talking about overwriting or appending. I can't get any tabs to come up at all--overwriting or appending. Guess I will just try to reinstall and go from there.
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.