Closed Bug 411549 Opened 12 years ago Closed 12 years ago

place:folder=x shows next to Location line in Library

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 3 beta5

People

(Reporter: marcia, Assigned: mano)

References

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

Seen using Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3pre) Gecko/2008010904 Minefield/3.0b3pre. I am using a fresh profile

STR:

1. Go to Bookmarks | Show Bookmarks and observe the text that appears in the line next to Location (see attached screenshot)
Assignee: nobody → mano
nominating to get on the radar.
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
OS: Mac OS X → All
Hardware: PC → All
Marcia:  What do you reckon the location should say for places folders?
Location field for items such as folders should be empty.  Or even better, the field shouldn't be present.
iow, the fields for special folders should probably be the same as for regular folders.
ah, yes..  Name: and Description: fields.  Just like a regular folder.
Comment 4 makes sense to me. It just looks weird the way it is now.
Queries are starting to generate some forum interest - http://forums.mozillazine.org/viewtopic.php?t=629560
http://forums.mozillazine.org/viewtopic.php?t=629714
- and making Location info harder to find and use is kind of a drag, at least pending Bug 399799 (which doesn't block).

Any chance of just moving the location field for "place:foo" type things below the More... button, and making the Location: text for critical folders (Menu, Toolbar and Unfiled, at least?) that non-editable, FYI-only-looking stuff? At least for now?
Priority: -- → P3
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 3 beta5
Attached patch quick (obsolete) — Splinter Review
Attachment #309088 - Flags: review?(dietrich)
Comment on attachment 309088 [details] [diff] [review]
quick


>-        gEditItemOverlay.initPanel(selectedNode.itemId,
>-                                   { hiddenRows: ["folderPicker"] });
>+        // Using the concrete itemId is argubally wrong. The bookmarks API

spelling nit: arguably

>+        // does allow setting properties for folder shortcuts as well, but since
>+        // the UI does not distinct between the couple, we better just show
>+        // the concrete item properties.
>+        if (selectedNode.type ==
>+            Ci.nsINavHistoryResultNode.RESULT_TYPE_FOLDER_SHORTCUT) {
>+          gEditItemOverlay.initPanel(asQuery(selectedNode).folderItemId,
>+                                     { hiddenRows: ["folderPicker"],
>+                                       forceReadOnly: true });
>+        }
>+        else {
>+          gEditItemOverlay.initPanel(selectedNode.itemId,
>+                                     { hiddenRows: ["folderPicker"] });
>+        }
> 

please document forceReadOnly in bookmarkProperties.js. and that documentation should either be moved to this file, or at least referenced here.
Attachment #309088 - Flags: review?(dietrich) → review+
Attached patch as checked inSplinter Review
mozilla/browser/components/places/content/editBookmarkOverlay.js 1.34
mozilla/browser/components/places/content/places.js 1.146
Attachment #309088 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
verified with: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b5pre) Gecko/2008031704 Minefield/3.0b5pre
Status: RESOLVED → VERIFIED
Duplicate of this bug: 426156
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.