All users were logged out of Bugzilla on October 13th, 2018

Assertion in nsImapServerResponseParser::BeginMessageDownload

VERIFIED FIXED in Future

Status

P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: mscott, Assigned: Bienvenu)

Tracking

Trunk
Future
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
When attempting to download new mail, I get an assertion in
nsImapServerResponseParser::BeginMessageDownload:

NS_ASSERTION(fSizeOfMostRecentMessage > 0, "most recent message has 0 or
negative size");

I see this consistently here at mail connect on the Novell -- NIMS server.
(Reporter)

Comment 1

19 years ago
Created attachment 9417 [details] [diff] [review]
novell nims log. Look at the very end

Updated

19 years ago
QA Contact: lchiang → huang
(Reporter)

Comment 2

19 years ago
it looks like the servers where we run into this, don't issue the message size
until after they issue the envelope response. So we eventually get the size,
just a little later than we would like.
Keywords: interop, nsbeta3
Target Milestone: --- → M20

Comment 3

19 years ago
*** Bug 12390 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 4

19 years ago
this just has to do with mpod and it's harmless. I'll look into it a little more.
Assignee: mscott → bienvenu

Comment 5

19 years ago
- per mail triage
Whiteboard: [nsbeta3-]
Target Milestone: M20 → Future
(Assignee)

Comment 6

18 years ago
accept to shut up bugzilla.
Status: NEW → ASSIGNED
(Assignee)

Comment 7

17 years ago
Created attachment 60168 [details] [diff] [review]
proposed fix

fix is to not do this assertion if we're downloading headers, as opposed to the
message body.
(Assignee)

Comment 8

17 years ago
cc'ing Cavin for review, fixing up keywords and status whiteboard.
Keywords: interop, nsbeta3
Whiteboard: [nsbeta3-]

Comment 9

17 years ago
Comment on attachment 60168 [details] [diff] [review]
proposed fix

r=cavin.
Attachment #60168 - Flags: review+
(Reporter)

Comment 10

17 years ago
Comment on attachment 60168 [details] [diff] [review]
proposed fix

rs=mscott
Attachment #60168 - Flags: superreview+
(Assignee)

Comment 11

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
verifying by code inspection for Karen since this assertion is a debug only
feature =).
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.