Root bookmark directory folders are not exported

RESOLVED DUPLICATE of bug 417228

Status

()

Firefox
Bookmarks & History
--
critical
RESOLVED DUPLICATE of bug 417228
11 years ago
9 years ago

People

(Reporter: Jonnan, Unassigned)

Tracking

({dataloss})

Trunk
x86
Windows XP
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

After the previous ticket, I reinstalled firefox and attempted to import bookmarks from previously (Prior to initial issue)created backups.

All folders I created in the root directory (I.E. not under Bookmarks toolbar, bookmarks menu, or unfiled bookmarks) are gone. Tags were also either not exported or not imported imported.

Reproducible: Always

Steps to Reproduce:
1. create directories in root bookmarks directory
2. export
3. import to new profile
Actual Results:  
Directories and bookmarks under Bookmarks toolbar and Bookmarks menu are reimported without tag information. 

Any bookmarks created outside these folders (including 'unfiled bookmarks' are gone.

Expected Results:  
Recreation of bookmarks and tagged information with the folder structure created in original profile.
(Reporter)

Updated

11 years ago
Component: Bookmarks → Places
Keywords: dataloss
QA Contact: bookmarks → places

Comment 1

11 years ago
I see the same behavior.  If I look into the html file generated by export command, I don't even see those additional folders exported.  Only "Bookmarks Toolbar" and "Bookmarks Menu" are exported.  The tags are also missing from the exported file.

This bug is probably related to bug 405936 and bug 405936.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 417228
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.