Firefox opens multiple proxy authentication prompts when starting

RESOLVED DUPLICATE of bug 339804

Status

()

Firefox
Session Restore
RESOLVED DUPLICATE of bug 339804
11 years ago
11 years ago

People

(Reporter: Stefan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b2) Gecko/2007121120 Firefox/3.0b2

At start-up firefox seams to prompt for each pages which comes from internet for the user to enter the proxy authentication password. 
(And by thus each time also for the master password)


Reproducible: Always

Steps to Reproduce:
1. Open several tabs in firefox, each tabs pointing to a different page behind the firewall.
2. Close firefox and save you tab session.
3. Open firefox again
Actual Results:  
For each open tab, a dialog box is loaded which prompt the user to enter the master password.
So the user has to enter the master password several times and confirm the proxy login dialog the same amount of times.


Expected Results:  
Only request the master password and proxy password once.
As long a dialog box is still open prompting for a password or login, 
don't ask a second time for the same login or password !!

This problem happens also in firefox 2.0.0.x browsers.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 339804
You need to log in before you can comment on or make changes to this bug.