Double-click-hold select does not work as it does in most OS X apps

VERIFIED DUPLICATE of bug 16203

Status

Camino Graveyard
General
--
minor
VERIFIED DUPLICATE of bug 16203
11 years ago
11 years ago

People

(Reporter: Joe Rickerby, Unassigned)

Tracking

Details

(Whiteboard: DUPEME)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.11) Gecko/20071128 Camino/1.5.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en; rv:1.8.1.11) Gecko/20071128 Camino/1.5.4

In most mac apps, double-clicking on a word and holding the second click allows you to select whole words- try this in the (presumably standard cocoa) google search box and then try it on a page- the behaviour is different.

Reproducible: Always

Steps to Reproduce:
1. Double-click-hold a word and drag across words either side of it.
Actual Results:  
The double-click selects the first word, but after that selection is character-by-character.

Expected Results:  
The double-click selects the first word, and afterwards selection should be whole words only.
This is a dupe of a Core bug that I can't find right now.
Whiteboard: DUPEME
(Reporter)

Comment 2

11 years ago
I wasn't sure if that was Windows behaviour so I filed it as a Camino bug.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 16203

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.