If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

{inc}list item images badly aligned on first load

VERIFIED DUPLICATE of bug 36703

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 36703
18 years ago
17 years ago

People

(Reporter: Amit J. Patel, Assigned: clayton)

Tracking

({css1})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The list item images on this page aren't to the left of the list items.
Instead, they are offset down and to the right.  They don't always show properly
when scrolling.  I'll attach an image if I can figure out how.

I had this problem on my own page (http://www-cs-
students.stanford.edu/~amitp/gameprog.html) but it went away when I fixed some
bad HTML/CSS.  So my guess is that Mozilla isn't dealing with bad HTML/CSS
properly, and some invalid values are getting into the style sheet.
(I haven't checked to see if ciwas-mFAQ.html validates, sorry, but Mozilla
shouldn't be rendering improper HTML this badly.)
(Reporter)

Comment 1

18 years ago
Created attachment 9420 [details]
Screenshot of list item images not rendering in the right place
Confirming bug.  This only happens the first time the page is loaded.  I think
the problem has to do with moving the image once it is loaded and the (nonzero)
image dimensions are available.  (Does that count as an incremental reflow bug? 
Marking as such.)

Testcase to be attached.  (Also need to check for duplicates.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: list item images don't line up properly → {inc}list item images badly aligned on first load
Created attachment 9497 [details]
simple testcase
Actually, I believe this is a duplicate of bug 36703, which is already
[nsbeta2+][6/15].

*** This bug has been marked as a duplicate of 36703 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: css1
Resolution: --- → DUPLICATE

Comment 5

17 years ago
The bug this was duped against is now fixed, and the testcase and test page now
render correctly with Linux build 2000103121. Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.