Very large ETag header causes response to be ignored

RESOLVED WONTFIX

Status

()

Core
Networking: HTTP
RESOLVED WONTFIX
11 years ago
2 years ago

People

(Reporter: Marc Haberkorn, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

I tried executing the same GET request three different ways: DOJO xhrGet() method, raw XHR object GET request, and standard address-bar URL entry, all using Firefox.   All three requests had the same problem - the response was ignored.  The Dojo xhrGet request said that the request had been cancelled.  

In all cases, I had a proxy between client and server, and could see that a 200 response code was sent to the browser, and that the response had content.  The strange thing was a very large ETag header (several thousand characters long).  I removed this header from the server's response, and the request was no longer ignored.  

I'm not sure what's happening under the covers in the browser, but I'm guessing that you don't want it to silently fail, but would rather either specify a useful error message stating what the problem was, or just handle it.  Safari and IE both worked fine.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

11 years ago
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → 1.8 Branch
probably the 10K header limit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.