Closed Bug 411736 Opened 15 years ago Closed 15 years ago

Drag and drop in multiview makes events disappear (applies to local and remote)

Categories

(Calendar :: Calendar Frontend, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 408657

People

(Reporter: thetux.moz, Unassigned)

Details

Attachments

(3 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/20080110 Calendar/0.8pre ID:2008011005

In multiweek events get lost (they just disappear while holding the mousebutton). You can get rid of all events this way. Disappeared events "come back" if you switch to another viewmodus and back. This bug is present at local and remote calendars.

Reproducible: Always

Steps to Reproduce:
1. Go to multiweek
2. create a event (or just take one you already have) and grab this 
3. move the mouse to another day

Actual Results:  
The selected event disappears

Expected Results:  
The selected event should have moved to the selected day.
Drag and drop of events in multiweek view work fine for me using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/20080110 Calendar/0.8pre. Tested with storage calendar in new profile.
mousecursor was not captured, just drew an arrow in it then
event is also disappering if you drag and drop it into the minical window
Attached file testevent
Works for me with the attached event using Lightning 2008011003 or Sunbird 20080110.
I can't reproduce it myself on Lightning 2008010904
Lars, if you are able to reproduce please check your error console. I assume that you are dragging over a <tree> and its producing exceptions. Try all trees you can find :)
Hi Philipp,

we think that this two exceptions comes from the Nightly Tester Tools 1.3b4

Error: brandbundle has no properties
Source File: chrome://nightly/content/calendar.js
Line: 14

Error: document.getElementById("nightly-breakpad-sidebar") has no properties
Source File: chrome://nightly/content/breakpad/breakpad.js
Line: 25


I let some more events disappear and got this:

Error: uncaught exception: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]

Error: [Exception... "'JavaScript component does not have a method named: "drop"' when calling method: [nsITreeView::drop]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: chrome://calendar/content/calendar-month-view.xml :: onxbldraggesture :: line 267"  data: no]
Source File: chrome://calendar/content/calendar-month-view.xml
Line: 267

Error: uncaught exception: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]

Error: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]
Source File: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js
Line: 167

Error: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]
Source File: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js
Line: 167

Error: uncaught exception: [Exception... "'<error>' when calling method: [calICalendar::addItem]"  nsresult: "0x804a0002 (<unknown>)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/eviltux/Desktop/sunbird-0.8pre.en-US.win32/sunbird/js/calTransactionManager.js :: cT_doTransaction :: line 167"  data: no]



I found out, that they all reappear if i click on multiweek again (even it is already "pressed"/activated).


I think the culprit is 

Error: [Exception... "'JavaScript component does not have a method named:
"drop"' when calling method: [nsITreeView::drop]"  nsresult: "0x80570030
(NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame ::
chrome://calendar/content/calendar-month-view.xml :: onxbldraggesture :: line
267"  data: no]
Source File: chrome://calendar/content/calendar-month-view.xml
Line: 267

In that case, this would be a dupe of bug 408657.

Lars, an example of how this should be done (for a different tree) is in the denoted bug, maybe you are interested in creating a patch for us?
Note: The 0x804a0002 error indicates that you are trying to edit or add an event in a read only calendar (see Bug 313640). You might want to retest with a writable calendar.
Stefan, I don't what I can do about it. It is a clean profile with just the home calendar. I doublechecked it: the calendar is not marked as read only.

I also noticed this:

Error: [Exception... "'JavaScript component does not have a method named: "getParentIndex"' when calling method: [nsITreeView::getParentIndex]"  nsresult: "0x80570030 (NS_ERROR_XPC_JSOBJECT_HAS_NO_FUNCTION_NAMED)"  location: "JS frame :: chrome://calendar/content/calendar-month-view.xml :: onxbldraggesture :: line 267"  data: no]
Source File: chrome://calendar/content/calendar-month-view.xml
Line: 267


I think this wasn't there before.
I have done crosscheck: when I set the calendar into read-only-mode, it is not possible to move the event.
the exception from c12 also means that the tree view is not implemented correctly. I'm marking this duplicate now.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 313640
Oops, wrong bug#
Duplicate of bug: 408657
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.