mouse drag and mouse up can cause firefox3.0beta2 to switch windows

VERIFIED DUPLICATE of bug 407876

Status

()

Core
Widget: Cocoa
VERIFIED DUPLICATE of bug 407876
10 years ago
10 years ago

People

(Reporter: joduinn, Assigned: Josh Aas)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

0) do clean install of FF3.0beta2
1) Have two firefox windows open, one partially overlapping the other.
2) click-and-hold-down anywhere in foreground window
3) drag mouse to be over anywhere in background window
4) release mouse, and notice that background window switches to be in foreground.

While I can reproduce this by clicking anywhere in the foreground window, its particularly annoying when you are scrolling, as its easy to accidently have the mouse drift out of the scrollbar area, and you find yourself suddenly after switching foreground windows.
This sounds like a Cocoa Widget bug I've seen recently, but I can't find it (or anything sounding like it) now.  Steven, has this been fixed recently, am I failing at searching, or just imagining having seen a bug report like this?
Assignee: nobody → joshmoz
Component: General → Widget: Cocoa
Product: Firefox → Core
QA Contact: general → cocoa
> This sounds like a Cocoa Widget bug I've seen recently

Smokey, I believe you're thinking of something that never got its own
bug, but was mentioned (as the "third problem") at the bottom of bug
407876 comment #2.

That's been fixed (by the patch for bug 407876).  But I believe the
patch was landed after beta 2 was finalized.

So, John, please try with a current Minefield nightly.  They're
available at ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly.
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 407876
Confirmed that this is fixed in ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2008-01-21-04-trunk on my mac. Also confirmed this was not a problem on win32 in 3.0beta2.

Thanks for the help!!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.