New Task with Due Date does not show in Month View unless Recurring Rule or Alarm Set

VERIFIED DUPLICATE of bug 349529

Status

VERIFIED DUPLICATE of bug 349529
11 years ago
11 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12pre) Gecko/20080110 Calendar/0.8pre

On Multiweek and Month Views a new task with only the Due Date set and without a recurring rule or alarm does not show until a recurring rule or alarm is set.  Task will continue to show if the rule or alarm is removed.



Reproducible: Always

Steps to Reproduce:
Turn on the 'Tasks in View' option if it isn't already.
Add a New Task.
Set the Due Date but NOT the Start Date
Do NOT set a recurring rule or an alarm
Save the Task.  The new task will not show in the calendar view.

---

Now edit the task that was just added.
Set a recurring rule or an alarm (or both)
Save the Task.  The task is now visible in the calendar view.

---

Edit the task again and remove the recurring rule and alarm
Save the Task.  It is still visible in the calendar view.



Expected Results:  
A Task will display in the calendar view regardless of alarm or recurring rule status as long as the 'Tasks in View' option is selected
With only due date the task is not displayed in view -> Bug 349529. Adding recurrence rule or alarm forces a start date to be set on the task -> task is visible. Removing the recurrence rule or alarm will not remove the start date -> task is still visible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349529
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.