[firefox-3.0b] <input type=file> , FilePicker is run by clicking the input text-field.

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
10 years ago
10 years ago

People

(Reporter: M. Uchida, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.9b2) Gecko/2008011114 Minefield/3.0b2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.9b2) Gecko/2008011114 Minefield/3.0b2

[firefox-3.0b] <input type=file> , FilePicker is run by clicking the input text-field, though by Not clicking the browse... button.
In firefox-2.0.0.10, I can input a file path into the input text-field of <input type=file>.
Is that specification of behavior for clicking the input text-field of <input type=file> changed ?


Reproducible: Always

Steps to Reproduce:
1.You build and install firefox-3.0b1 or firefox-3.0b2
2.open the web pages including <input type=file>.
3.click the input text-field of <input type=file>.
Actual Results:  
If you click the input text-field of <input type=file>, FilePicker is always run.

Expected Results:  
I can input a file path into the input text-field of <input type=file> without running FilePicker, like case of firefox-2.0.0.10.

None.
(Reporter)

Updated

10 years ago
Summary: [firefox-3.0b] <input type=file> , FilePicker is run by clicking the input text-field. → [firefox-3.0b] <input type=file> , FilePicker is always run by clicking the input text-field.
This is behaving as expected. Disabling the use of the text part as a text control took place in bug 258875
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Summary: [firefox-3.0b] <input type=file> , FilePicker is always run by clicking the input text-field. → [firefox-3.0b] <input type=file> , FilePicker is run by clicking the input text-field.
Duplicate of this bug: 442295
Duplicate of this bug: 442295
You need to log in before you can comment on or make changes to this bug.