install-module.pl aborts when trying to install DBD::Oracle

RESOLVED FIXED in Bugzilla 3.2

Status

()

Bugzilla
Installation & Upgrading
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Clement Chan, Assigned: Max Kanat-Alexander)

Tracking

3.1.2
Bugzilla 3.2
Bug Flags:
approval +
blocking3.1.3 +

Details

Attachments

(1 attachment)

v1
877 bytes, patch
Max Kanat-Alexander
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.10) Gecko/20070223 CentOS/1.5.0.10-0.1.el4.centos Firefox/1.5.0.10
Build Identifier: Bugzilla 3.1.2

When I ran install-module.pl to set up bugzilla 3.1.2 for all the
required perl modules, the script aborts by not finding the
ORACLE_HOME environment variable. To work around, I have to comment
out the 'oracle' entry in Bugzilla::Constants::DB_MODULE. 

Reproducible: Always

Steps to Reproduce:
1. untar Bugzilla 3.1.2
2. cd bugzilla-3.1.2
3. perl install-module.pl
Actual Results:  
ORACLE_HOME not found error

Expected Results:  
It should provide a mean to handle the error gracefully, simular to checksetup.pl --CHECK-MODULE.

Comment 1

10 years ago
If ORACLE_HOME is undefined, install-module.pl shouldn't try to download and install DBD::Oracle. It should rather display something like:

ORACLE_HOME undefined, skipping DBD::Oracle

and should continue with the remaining installation. This means this script is unusable for most users as probably nobody has this ENV variable set.

Leaving as UNCO as I didn't try to run install-module.pl.
Flags: blocking3.1.3?
OS: Linux → All
Hardware: PC → All
Version: unspecified → 3.1.2
(Assignee)

Updated

10 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

10 years ago
Created attachment 296623 [details] [diff] [review]
v1

This fixes it. Turns out I was also trying to install each DBD module twice.
Assignee: installation → mkanat
Status: NEW → ASSIGNED
Attachment #296623 - Flags: review+
(Assignee)

Updated

10 years ago
Flags: blocking3.1.3?
Flags: blocking3.1.3+
Flags: approval+
(Assignee)

Comment 3

10 years ago
Checking in install-module.pl;
/cvsroot/mozilla/webtools/bugzilla/install-module.pl,v  <--  install-module.pl
new revision: 1.2; previous revision: 1.1
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Summary: install-module.pl abort by oracle DB_MODULE → install-module.pl aborts when trying to install DBD::Oracle
Target Milestone: --- → Bugzilla 3.2
You need to log in before you can comment on or make changes to this bug.