Closed Bug 411987 Opened 14 years ago Closed 14 years ago

"show my windows and tabs from last time" breaks the default browser check

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 390060

People

(Reporter: gradies, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071231 Firefox/2.0.0.11 Flock/1.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071231 Firefox/2.0.0.11 Flock/1.1a1pre

When you choose to restore your windows and tabs every time you open your browser then the default browser check upon startup is not getting triggered.

Reproducible: Always

Steps to Reproduce:
1. open the main tab in the options
2. select "show my windows and tabs from last time"
3. close firefox
4. Open a browser that isn't firefox. Select "yes" when given the option of changing your default browser.
5. Open Firefox
Actual Results:  
Firefox opens but it does not present the option to restore it as your default browser. 

Expected Results:  
As long as "always check to see if firefox is the default browser on startup" is checked then you should see a message asking if you'd like to restore it as your default browser.

Flock will be upstreaming a fix for this shortly
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390060
You need to log in before you can comment on or make changes to this bug.