Closed Bug 411992 Opened 12 years ago Closed 12 years ago

Images received in the body of emails are incomplete or do not display completely.

Categories

(Thunderbird :: Mail Window Front End, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 390795

People

(Reporter: mark.mooney, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

Inbound emails which include images or pictures in the body of the email do not complete or are cut off. This issue is only present when using an imap account under thunderbird. It does not happen if the email is in a pop3 account under thunderbird.

Reproducible: Always

Steps to Reproduce:
1.Have someone send you an email with an image or picture in the body of the email.
2.
3.
Actual Results:  
The top edge of the picture or image will only be displayed.

Expected Results:  
Full picture or image viewed in the body of the email.
Severity: normal → major
Is there any difference in "View/Message Source" between mail via IMAP and mail via POP3?
(In reply to comment #3)
> Is there any difference in "View/Message Source" between mail via IMAP and mail
> via POP3?
> 

Yes, the email with the incomplete image is shorter that the email with the complete image. There is more code for the complete image. There are no other differences.
There are at least two types of bug of short downloaded attachment when IMAP.
  (a) Tb's fault     : Bug 384819
  (b) Server's fault : Bug 390795(non MS Exchange), Bug 92111(MS Exchange)
See also Bug 405440. Both (a) & (b) seem to be involved in his case.

"Somehow short attachment data when IMAP" is same status as Bug 330829.
(Bug 330829 is still unclear whether (a) or (b) or both or new problem.)
See Bug 330829 Comment #11, and get IMAP protocol log, and if Tb's fault is involved, attach log file to this bug(never paste to this bug).
Workaround....
> 
> user_pref(mail.server.serverXX.fetch_by_chunks, false);
> 
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Probably a dupe of bug 390795 then.
(FIXED is only used when known code changes resolved the issue)
Resolution: FIXED → DUPLICATE
Duplicate of bug: 390795
You need to log in before you can comment on or make changes to this bug.