Ftp listing: Mangled symbols in long cyrillic filename

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
11 years ago
3 years ago

People

(Reporter: unghost, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 296621 [details]
Screenshot

With beautified ftp file listing: if long cyrillic filename is truncated, there are mangled symbols present alongside ellipsis.
STR:
1) Open ftp://ftp.mozilla-russia.org/test/
2) Set encoding to UTF-8
Actual result:
In file with name consisting from cyrillic letters mangled symbols present alongside ellipsis. There is no issue for file with name consisting from latin letters.

Cc'ing Dão Gottwald as it's probably regression from Bug 294800
Screenshot is attached

Comment 1

11 years ago
sounds like bug 391472 to me

Comment 2

11 years ago
Btw, I wonder why the table overflows the page. As far as I remeber, text used to break after "…" when the cropping was implemented.

Updated

11 years ago
Blocks: 294800
(Reporter)

Comment 3

11 years ago
(In reply to comment #1)
> sounds like bug 391472 to me
> 
It's bit hard for me to understand what Bug 391472 about. Looks like it describe issue with combining chars for languages like Hebrew and such. I'm not sure that there are combining chars in Russian language.

(Reporter)

Comment 4

11 years ago
(In reply to comment #2)
> Btw, I wonder why the table overflows the page. As far as I remeber, text used
> to break after "…" when the cropping was implemented.
> 
Looks like regression, It regressed between a8 and b1, I'll open new bug for it when I'll find exact time of regression.
(Reporter)

Comment 5

11 years ago
(In reply to comment #2)
> Btw, I wonder why the table overflows the page. As far as I remeber, text used
> to break after "…" when the cropping was implemented.
> 
I filed Bug 412023

Comment 6

10 years ago
Was this bug fixed, too?  (Can't test -- the ftp URL is now unavailable.)
(Reporter)

Comment 7

10 years ago
(In reply to comment #6)
> Was this bug fixed, too?
No. Tested in Mozilla/5.0 (X11; U; Linux i686; ru; rv:1.9.1b2pre) Gecko/20081122 Minefield/3.1b2pre ID:20081122072820

>(Can't test -- the ftp URL is now unavailable.)
I've restored test ftp URL.

Comment 8

7 years ago
Created attachment 551266 [details]
Another example (page source)

I probably have a similar problem. This is how page source looks.

This is a filename returned by FTP server (in IBM866 encoding):

╨Ч╨▓╨╡╨╖╨┤╨╜╤Л╨╡ ╨▓╨╛╨╣╨╜╤Л ╨н╨┐╨╕╨╖╨╛╨┤ 2 - ╨Р╤В╨░╨║╨░ ╨Ъ╨╗╨╛╨╜╨╛╨▓  [2].sub
only critical ftp fixes now
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: Networking → Networking: FTP
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.