Prism won't run in Rosetta on Intel Mac

RESOLVED DUPLICATE of bug 446359

Status

Mozilla Labs
Prism
RESOLVED DUPLICATE of bug 446359
11 years ago
10 years ago

People

(Reporter: Zach Tuckwiller, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/523.12.2 (KHTML, like Gecko) Version/3.0.4 Safari/523.12.2
Build Identifier: Prism 0.8

When you Get Info on Prism, it is listed as a Univeral Application, but it cannot be set to run in Rosetta.  I use a web app that would be best used in Prism, but the app uses Shockwave.  Shockwave doesn't run natively on Intel Macs, but will work within applications that are running in Rosetta.  Since it's Universal, it should be able to run in Rosetta, but you can't enable it to run in Rosetta.

Reproducible: Always

Steps to Reproduce:
1. In the Finder on an Intel Mac, highlight Prism.
2. Under the File Menu, select Get Info.
3. Check the box next to Open Using Rosetta.
4. Close the Get Info window.
5. Highlight Prism.
6. Under the File Menu, select Get Info a second time.
7. You'll see the box you checked previously to Open Using Rosetta is no longer checked.
Actual Results:  
Prism will not open using Rosetta, so webpages that use Shockwave can't use Prism.`

Expected Results:  
It should have held the setting to Open Using Rosetta, and opened in Rosetta emulation mode.

Comment 1

11 years ago
Double check that it's listed as a Universal Application. I downloaded Prism 0.9 to a G5 and it's an Intel only application. So, that would explain why it won't run under Rosetta.
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> Double check that it's listed as a Universal Application. I downloaded Prism
> 0.9 to a G5 and it's an Intel only application. So, that would explain why it
> won't run under Rosetta.
> 

If you visit the URL listed in the bug, you'll note that 0.8, for which this bug was submitted, identified itself as a Universal Application, and included the checkbox option to run in Rosetta in its information window.  0.8 ran on PPC machines as well. I haven't investigated 0.9.  It wasn't out at the time the bug was submitted.

Comment 3

11 years ago
(In reply to comment #2)
> If you visit the URL listed in the bug, you'll note that 0.8, for which this
> bug was submitted, identified itself as a Universal Application, and included
> the checkbox option to run in Rosetta in its information window.  0.8 ran on
> PPC machines as well. I haven't investigated 0.9.  It wasn't out at the time
> the bug was submitted.

Sorry about that. You're right - I didn't see the 0.8

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 446359
You need to log in before you can comment on or make changes to this bug.