Need pref to turn off fx-minefield-initiated virus scan of downloads

VERIFIED DUPLICATE of bug 393792

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 393792
11 years ago
10 years ago

People

(Reporter: Ed Hume, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011005 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008011005 Minefield/3.0b3pre

Automatic scanning of downloads for viruses is duplicative for some of us (our AV packages do it anyway) and the minefield-initiated scan takes a long time. See this thread for examples:

http://forums.mozillazine.org/viewtopic.php?t=614372

We need a pref to turn this off; preferably we need a UI so that messing with about:config is not needed. We could also use a method to cancel a scan that is taking too long.

Reproducible: Sometimes

Steps to Reproduce:
1. Download a big file (e.g. - a compressed file).
2. Watch the virus scanner at work.

Actual Results:  
In some systems the scanner takes a long time. 50 seconds is not unusual. This disables minefield while it is working.

There is no way to cancel the scan in progress.
There is no way to cancel automatic scanning.

Expected Results:  
Scanning would proceed invisibly, initiated by the user's anti-virus software. If a user runs into this delay, there should be a way to turn off this duplicative scan.

I hate to bring up IE, but I have never seen this behavior in IE. And AVG still scans the downloads.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393792
see also bug 407657
Verified dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

11 years ago
This is not a full dup of 393792. This bug is addressing solely the issue of being able to cancel the automatic scan, which for some of us is a second download scan.
Please read bugs before you make comments.
He reported 2 things(which makes this bug report invalid): 
a) disable the scan per preferences b) cancel the scan

duped to a and for b see comment ä2
Matti: your last sentence is garbled.

I don't believe this is a dup yet, and anyway it seems important to address the reports of severe performance effects. Blaming extant AV software is not going to cut it when the causal link users can see involves Firefox 3, not AV changes. Suggesting reopen (I won't do it yet).

/be

Comment 7

11 years ago
in comment 5, b was "see comment 2". this bug is indeed invalid as described in comment 1 and should certainly not be reopened as both pieces are covered by previously filed bugs.
As bug triager i can only dupe bugs and this whole bug report is covered in 2 other bugs (see comment #1 and comment #2). The decision for wontfix is not my decision, it's the decision of someone else (sdwilsh@forerunnerdesigns.com) because I usual have not the rights to mark bugs wontfix.

bug 412204 is still open because it's not covered by other bugs (it's about the bad performance and double-scan issue) and I agree that it's a bad idea to blame the AV companies when users have a bad experience with the DM in Firefox.
There must be IMHO a way to disable it or without another pref to cancel the scan in the DM. 

I think you should continue in bug 412204
Thanks -- first mention of bug 412204 I've seen.

/be
(And please, all, add value to bug 412204, rather than deluging with well-meaning--but repeated--information.)
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.