<li> contents doesn't wrap around floating <div>

RESOLVED DUPLICATE of bug 163110

Status

Core Graveyard
GFX
RESOLVED DUPLICATE of bug 163110
11 years ago
10 years ago

People

(Reporter: Daniel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

<li> contents has constant width near floating <div> and below it.

Reproducible: Always

Steps to Reproduce:
Load this page:

<div style="width:150px">
<div style="width:50px; height:50px; border:1px solid; float:right"></div>
<p>text text text text text text text text text text text text text text</p>
</div>

<div style="width:150px">
<div style="width:50px; height:50px; border:1px solid; float:right"></div>
<ul>
<li>text text text text text text text text text text</li>
<li>text text text text text text text text text text</li>
</ul>
</div>

Actual Results:  
1st <li> contents has constant width

Expected Results:  
1st <li> contents width should change to 100% below floating div

This work as expected in IE 7 and Opera 9.2

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 163110
(Assignee)

Updated

10 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.