Cannot enter text into Composer (win95)

VERIFIED FIXED in M16

Status

()

Core
Editor
P3
blocker
VERIFIED FIXED
18 years ago
16 years ago

People

(Reporter: John Morrison, Assigned: mjudge)

Tracking

({smoketest})

Trunk
x86
Windows 95
smoketest
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dogfood+])

(Reporter)

Description

18 years ago
Overview Description:
  Cannot enter text into Composer (no how, no way)

Steps to Reproduce:
1) Start Browser, launch composer
2) Debug->Insert Text or just typing at the keyboard

Actual Results:
  No text is entered into the document

Expected Results:
  ...

Reproducibility: always

Build Date & Platform Bug Found:
  2000060109 win95

Additional Builds and Platforms Tested On:
  linux has bug #41206 already filed where the text is not initially
  visible, but in this case, no text can be entered at all

Additional Information:

From the console:


WEBSHELL+ = 7
WEBSHELL+ = 8
JavaScript error:
 line 0: this.boxObject has no properties

WEBSHELL+ = 9
JavaScript error:
chrome://editor/content/EditorCommandsDebug.js line 64: editorShell has no 
properties
(Reporter)

Comment 1

18 years ago
add smoketest keyword ...
Keywords: smoketest

Comment 2

18 years ago
hmm, 200060108 win98 mozilla build does not show this..I can type inside and see
the text without a problem.

Comment 3

18 years ago
I also don't see this in my Win32 build from around 9:30am this morning.
(Reporter)

Comment 4

18 years ago
Then it sounds like a commercial build packaging issue (i.e., hand-rolled is 
OK, mozilla opt. build is OK).

Comment 5

18 years ago
assigning to Mike for the moment, Mike this may be a dup of 41088
Assignee: beppe → mjudge
Target Milestone: --- → M16

Comment 6

18 years ago
I don't see any problem under NT in this morning's debug build.

Comment 7

18 years ago
packaging issue?  did someone add files to the build and not update the 
packages-win file?

Comment 8

18 years ago
Putting on [dogfood+] radar.
Whiteboard: [dogfood+]
(Assignee)

Comment 9

18 years ago
commercial tree only. mozilla build from same sweetlou directory works fine. not 
m16 blocker but still a problem we are currently working on.
Status: NEW → ASSIGNED

Comment 10

18 years ago
One more data point ... I tried swapping in my chrome and res directories from 
my debug build, but that did not fix anything, so we can rule out any XUL/css 
differences between commercial and mozilla debug.

Comment 11

18 years ago
This was because of a packaging issue. raptor.xpt was missing from the windows 
package list.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 12

18 years ago
I assume raptor.xpt is a cross platform file.  Ws it added to packages-mac and 
pakcages-unix too?  If not, please do so.  Thanks.

Comment 13

18 years ago
verified in 6/4 build.
Status: RESOLVED → VERIFIED

Updated

17 years ago
Blocks: 46893

Updated

17 years ago
No longer blocks: 46893
You need to log in before you can comment on or make changes to this bug.