Last header line in dialogues/sheets is cut off

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
11 years ago
4 years ago

People

(Reporter: markus.magnuson, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en; rv:1.9b3pre) Gecko/2008011102 Camino/2.0a1pre (like Firefox/3.0b3pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.5; en; rv:1.9b3pre) Gecko/2008011102 Camino/2.0a1pre (like Firefox/3.0b3pre)

Several dialogue windows/sheets have the last line of the header cut off, this is only visible if the line contains letters with descending tail (like p, q, y, etc.)

See attached screenshots for examples.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
Created attachment 296781 [details]
Example 1

Pay attention to the word "open" in the header.
(Reporter)

Comment 2

11 years ago
Created attachment 296782 [details]
Example 2

Pay attention to the word "Warning" in the header
We used to have a bug about the bottom of the text in sheets being cut off, but I can't find it now.  Chris, do you remember that one?  

I'd like to make sure this is not that one before confirming (since Markus is right; this is definitely happening, on 10.3 and 10.5).

Comment 4

11 years ago
I think that one -- which I also can't find -- was about only the last n line(s) of text being cut off, not a line-height problem. This looks like the line height is too short, rather than being confined to the last line of text in the dialog.

cl

Comment 5

11 years ago
Found it: bug 327954, and my comment 7 suggests that maybe these are the same issue. The difference, though, is that the Javascript sheets are generated in code, whereas the alert sheets this bug is concerned with are standard Cocoa alerts that we don't (AFAIK) have much control over. It might be an OS issue.

Comment 6

11 years ago
(In reply to comment #5)
> whereas the alert sheets this bug is concerned with are standard Cocoa alerts

No, they are windows that we construct manually in code. In addition to tweaking the sizing for 10.3/10.4, we should look into creating a 10.5+ codepath for those alerts that uses NSAlert with either an accessoryView or a suppressionButton (depending on the need), and deprecate the entire manual codepath.

Confirming since the other issue is with the explanatory text size, rather than the header, which while related is probably not the same code.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Last header line in dialogues is cut off → Last header line in dialogues/sheets is cut off
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.