Last Comment Bug 412202 - Long text strings in reminder should use line breaks and not scroll horizontally
: Long text strings in reminder should use line breaks and not scroll horizontally
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Alarms (show other bugs)
: unspecified
: All All
-- enhancement (vote)
: 4.4
Assigned To: Merike Sell (:merike)
:
:
Mentors:
: 1092552 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-13 14:37 PST by Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout)
Modified: 2015-08-07 03:14 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Horizontal scrolling (32.62 KB, image/png)
2011-07-17 07:44 PDT, Merike Sell (:merike)
no flags Details
Possible solutions (54.75 KB, image/png)
2011-07-17 07:53 PDT, Merike Sell (:merike)
no flags Details
bug412202_wrap (2.97 KB, patch)
2015-07-15 04:57 PDT, Merike Sell (:merike)
philipp: review+
Details | Diff | Splinter Review

Description User image Sebastian Hengst [:aryx][:archaeopteryx] (needinfo on intermittent or backout) 2008-01-13 14:37:50 PST
Long text strings in reminder should use line breaks and not scroll horizontally. At the moment, long event titles are shown in one line and the window has a horizontal scroll bar. This should generally be performed for strings used in the reminder, if possible.
Comment 1 User image Martin Schröder [:mschroeder] 2008-02-13 18:22:04 PST
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.13pre)
Gecko/20080212 Lightning/0.8pre (2008021219) Thunderbird/2.0.0.13pre.

Christian, how should we handle events with long titles in the alarm dialog?
Comment 2 User image Felix Möller 2011-02-08 06:12:10 PST
Sadly no screenshot attached I think this is now covered in bug #570124
Comment 3 User image Merike Sell (:merike) 2011-07-17 07:44:39 PDT
Created attachment 546418 [details]
Horizontal scrolling

This doesn't seem to be covered by #570124, still broken with source from 11th July.
Comment 4 User image Merike Sell (:merike) 2011-07-17 07:53:59 PDT
Created attachment 546421 [details]
Possible solutions

Both making cropping work again and wrapping to multiple lines would fix this bug. Which one is wanted though?
Comment 5 User image Felix Möller 2011-07-17 08:57:51 PDT
Hi Merike, thanks for the screenshots, now the problem should be clear. The issue I mentioned in comment #2 has nothing to do with this at all.

I really like the second idea, that looks great. In addition I sometimes have events which have their difference just in the last letters ...
Comment 6 User image Philipp Kewisch [:Fallen] 2014-12-19 04:35:52 PST
*** Bug 1092552 has been marked as a duplicate of this bug. ***
Comment 7 User image Merike Sell (:merike) 2015-07-15 04:57:44 PDT
Created attachment 8634038 [details] [diff] [review]
bug412202_wrap

How about after all these years we actually fix this bug :)
Going for the second option here where title and location wrap to multiple lines when necessary.

Note You need to log in before you can comment on or make changes to this bug.