qm-win2k3-01 burns. constantly.

RESOLVED WORKSFORME

Status

Release Engineering
General
--
major
RESOLVED WORKSFORME
11 years ago
5 years ago

People

(Reporter: philor, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
There seem to be two primary errors: "INTERNAL: readdir: Bad file number" and a "buildbot.slave.commands.TimeoutError: SIGKILL failed to kill process" that looks like make just died somewhere at random. At the moment, we've had a TimeoutError, two readdirs, two successes, a TimeoutError, then a nice run of six successes, since last midnight.

Usually, it's not a big problem, since everyone just ignores qm-win2k3-01 (oh, wait, that *is* a big problem), but with qm-winxp01 also broken, it makes things awkward.

While looking at the logs, I noticed that qm-winxp01 (which doesn't suffer from this particular pair of problems) is building with |mk_add_options MOZ_MAKE_FLAGS="-j2"| while qm-win2k3-01 is using -j3, but I'm not authorized to see bug 370393, which made it so, to see if there's a reason for that.
no great reason for the difference in job numbers. win2k3 is running on real hardware and should have more resources for doing parallel jobs. This shouldn't really present a problem.

The main reason I think these two differ is that one is mozilla-build (win2k3) and the other is still using cygwin. I think the process handling in cygwin is a little more forgiving than mozilla-build's but don't have any proof other than "winxp machine seems more stable than win2k3".

Ignoring either of these machines is definitely a problem, and it needs to be fixed.
(Reporter)

Updated

11 years ago
Depends on: 413932
This is still happening (both winxp01 being perpetually orange and win2k3-01 being busted with "bad file number", and it's causing the tree to be closed right now, since it means we have no Windows unit test coverage (and we happen to be waiting for a test failure fix to clear).
Related/Duplicate of bug 381004 ?

NB: Currently, there is no (more ?) "qm-win2k3-01" nor "qm-winxp01" on FF tinderbox page...
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Mass move of Core:Testing bugs to mozilla.org:ReleaseEngineering. Filter on RelEngMassMove to ignore.
Component: Testing → Release Engineering
Product: Core → mozilla.org
QA Contact: testing → release
Version: Trunk → other
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.