window.openDialog core dumps if you use the same name twice

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Pete Collins (MDG), Assigned: Dan M)

Tracking

Trunk
x86
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If you name the window you are opening something other than "_blank", and try to
open it again, she core dumps.

For example, if i call the window "win1", it will launch the first time.
If i call the same function again while the window is open and use the same
name, we die miserably.

window.openDialog( "chrome://navigator/content/", "win1",
"chrome,all,dialog=no"+args, url );

Comment 1

18 years ago
I can't reproduce the crash on win95, but I know there is a problem in this
area -- see bug #25040. (Say Pete -- do you have a small test case that 
crashes, by any chance). 

Comment 2

18 years ago
reassigning to danm 
Assignee: trudelle → danm
(Assignee)

Comment 3

18 years ago
Can't reproduce. My test case:

<html><body>
  <button type=button onclick="window.openDialog('chrome://navigator/
content','win1','chrome,all,dialog=no')">Open Named Window</button>
</body></html>

does show a different distressing regression, that an attempt to open a named 
window won't find an extant window with the same name but will instead make a 
brand new window. (I tried this on redhat linux 6.0 and Windows NT 2000, with a 
build made from today's source.)

But that's a different bug. My guess is the problem you're noticing has something 
to do with some of those other unspecified parameters hinted at in the original 
bug writeup.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

18 years ago
var width="400";
var height="400";
var x="10";
var y="10";


var args = "width="+width+",height="+height+",screenX="+x+",screenY="+y;

window.openDialog( "chrome://navigator/content/", "_blank",
"chrome,all,dialog=no"+args, url );

danm, this is the actual code, i just filled in the variable values for now. If
this runs for you, then i guess it is fixed in the current builds.

pete
(Assignee)

Comment 5

18 years ago
  Well I tried that (still don't know what "url" is; I just give it something in 
an http://) and still didn't crash, but did notice that the size and position 
parameters seem to be ignored. &#@"$^#(#& #*&# "# #<"#$(#&$#@ ##.
(Reporter)

Comment 6

18 years ago
Ok, Dan. I guess it is fixed now.

I will reopen this bug if i run into any problems again.

Thanks

pete
You need to log in before you can comment on or make changes to this bug.