when modifying "command" attribute on a button, only oncommand is updated.

RESOLVED DUPLICATE of bug 391002

Status

()

RESOLVED DUPLICATE of bug 391002
11 years ago
10 years ago

People

(Reporter: arno, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Hi,

let's imagine a button with an attribute "command". The related <command/> has a "oncammand" attribute, and other attributes (such label or accesskey).

When modifying the "command" attribute to set it to another <command/> element, oncommand attribute is updated (ie: action is the action of second command), but other attributes are not (ie: label does not change).

I'll attach a testcase.
(Reporter)

Comment 1

11 years ago
Created attachment 296976 [details]
testcase: oncommand is updated (alert('cmd2')) but label is not (cmd1)

Updated

11 years ago
Keywords: testcase
Component: Layout → XP Toolkit/Widgets: XUL
QA Contact: layout → xptoolkit.xul
(Reporter)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 391002

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: xptoolkit.xul → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.