Last Comment Bug 412333 - firefox crashes when totem browser plugins should shown
: firefox crashes when totem browser plugins should shown
Status: VERIFIED DUPLICATE of bug 378911
: regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://teledyski.onet.pl/10172,279413...
: 412592 423069 424322 425082 434233 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 12:17 PST by Jakub 'Livio' Rusinek
Modified: 2008-07-15 08:59 PDT (History)
13 users (show)
dsicore: blocking1.9-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Console output after crash (2.20 KB, text/plain)
2008-04-03 07:37 PDT, Rubén Martín [:Nukeador]
no flags Details
Console output in debugging mode (4.03 KB, text/plain)
2008-07-14 03:45 PDT, Dave Farrance
no flags Details

Description Jakub 'Livio' Rusinek 2008-01-14 12:17:48 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008011404 openSUSE/10.3 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008011404 openSUSE/10.3 Minefield/3.0b3pre

firefox works great with flash player, but not with native totem's browser plugin.

Reproducible: Always

Actual Results:  
firefox crashes.

Expected Results:  
everything ok.
Comment 1 Matthias Versen [:Matti] 2008-01-14 13:26:49 PST
see also bug 378911 and please provide a breakpad if of that crash.
http://kb.mozillazine.org/Breakpad
Comment 2 Jakub 'Livio' Rusinek 2008-01-14 13:50:29 PST

*** This bug has been marked as a duplicate of bug 378911 ***
Comment 3 Matthias Versen [:Matti] 2008-01-18 05:57:52 PST
*** Bug 412592 has been marked as a duplicate of this bug. ***
Comment 4 Pascal Chevrel:pascalc 2008-01-18 06:24:53 PST
> see also bug 378911 and please provide a breakpad if of that crash.
http://kb.mozillazine.org/Breakpad

Matthias, when the application crashes, Reported is not launched and there is no /pending/ folder being created in /<directory>/<where>/<firefox>/<is/<installed>/crashreporter

Is there a bug with breakpad about the Linux version of Firefox? I'd love to be able to provide more information about crashes to help, that's actually why I use nightly builds
Comment 5 Matthias Versen [:Matti] 2008-01-18 07:15:11 PST
It's possible that it failed to catch the crash caused by an external plugin...
Comment 6 Pascal Chevrel:pascalc 2008-01-18 09:48:18 PST
my bug #412592 was duped to this one which might be correct (not much details here), but this bug was duped to bug #378911 which is in Unconfirmed state and is definitely a different issue.

I have tried builds to get back to where the regression to my bug was introduced and it was between 2007080204 and 2007080304, that is just after Alpha 7. I do not experience any problem before alpha 7 and bug #378911 is about a problem in alpha 4.
Comment 7 Rubén Martín [:Nukeador] 2008-03-16 08:26:58 PDT
I get the crash with Totem and also with VLC Plugin.

Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4

Definitely this bug is not duped to bug #378911
Comment 8 Pascal Chevrel:pascalc 2008-03-16 08:32:39 PDT
reopening since this is not a totem only issue
Comment 9 Matthias Versen [:Matti] 2008-03-26 13:26:55 PDT
*** Bug 425082 has been marked as a duplicate of this bug. ***
Comment 10 Jakub 'Livio' Rusinek 2008-03-26 13:43:56 PDT
What the hell is going on?

Bugs remain open, browser crashes with popular plugins and you're talking to Reuters that Firefox is almost ready...
Comment 11 Rubén Martín [:Nukeador] 2008-03-26 14:31:14 PDT
Same behavior with the latest nightly:

Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9b5pre) Gecko/2008032604 Minefield/3.0b5pre
Comment 12 Johnny Stenback (:jst, jst@mozilla.com) 2008-03-27 15:08:19 PDT
Are people still crashing with the latest version of the totem player (2.23.0)?
Comment 13 Johnny Stenback (:jst, jst@mozilla.com) 2008-03-27 16:06:41 PDT
Personally I have yet to see totem (2.20.1) crash here.
Comment 14 Rubén Martín [:Nukeador] 2008-03-27 16:52:38 PDT
The bug also affects to other multimedia plugins, like VLC (Version 0.8.6c), not just Totem.
Comment 15 Johnny Stenback (:jst, jst@mozilla.com) 2008-03-27 17:40:33 PDT
Nukeador, if you can reproduce this crash then please attach a gdb stack traces or use breakpad to give us something to go on. W/o some help here I doubt we'll get this fixed any time soon.
Comment 16 Jakub 'Livio' Rusinek 2008-03-27 22:46:46 PDT
Too much dependencies from Rawhide to upgrade Totem, sorry, I can't test it without breaking my system.
Comment 17 Damon Sicore (:damons) 2008-04-01 14:15:31 PDT
-'ing this based on Comment #15.  I know Johnny spent time on this, so any help
here appreciated to reproduce.

Comment 18 Rubén Martín [:Nukeador] 2008-04-03 07:37:21 PDT
Created attachment 313356 [details]
Console output after crash

Here it is the only thing I could send, the console output. Breakpad does not launch after crash.

The test was done with beta 5 with a new profile under Ubuntu 7.10
Comment 19 timeless 2008-04-03 07:46:51 PDT
Plugin is built incorrectly (missing proper glue)
Comment 20 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2008-05-17 16:30:32 PDT
*** Bug 434233 has been marked as a duplicate of this bug. ***
Comment 21 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2008-05-17 16:31:32 PDT
*** Bug 423069 has been marked as a duplicate of this bug. ***
Comment 22 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2008-05-17 16:32:58 PDT
*** Bug 424322 has been marked as a duplicate of this bug. ***
Comment 23 Martijn Wargers [:mwargers] (gone per 2016-05-31 :-( ) 2008-05-17 16:36:12 PDT
Maybe the totem plugin should be considered for blacklisting, like QuickTime plug-in version 7.1  in bug 430826?
Comment 24 Lalit 2008-05-17 17:07:39 PDT
(In reply to comment #23)
> Maybe the totem plugin should be considered for blacklisting, like QuickTime
> plug-in version 7.1  in bug 430826?
> 
I have seen the crashes on Vista too and there is no totem plugin for windows
VLC 0.8.6e crashes under both Vista and Linux 
but breakpad almost never launches when a plugin crashes 
is there something wrong in the way breakpad is invoked???
Comment 25 Lalit 2008-05-17 17:12:32 PDT
[00000331] main video output warning: late picture skipped (650417)
[00000001] main private debug: removing all interfaces
[00000287] main interface debug: thread 2809129872 joined (interface/interface.c:258)
[00000287] main interface debug: removing module "screensaver"
[00000285] main interface debug: thread 2817522576 joined (interface/interface.c:258)
[00000285] main interface debug: removing module "hotkeys"
[00000001] main private debug: removing playlist handler
[00000284] main private debug: thread 3023969168 joined (playlist/playlist.c:247)
[00000289] main input debug: control type=0
[00000289] main input debug: control: stopping input
[00000289] main input debug: closing input
[00000293] avi private debug: free chunk avih
[00000293] avi private debug: free chunk strh
[00000293] avi private debug: free chunk strf
[00000293] avi private debug: free chunk JUNK
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk strh
[00000293] avi private debug: free chunk strf
[00000293] avi private debug: free chunk JUNK
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk RIFF
[00000293] avi private debug: free chunk LIST
[00000294] main demuxer debug: removing module "avi"
[00000291] main access debug: removing module "access_http"
[00000297] ffmpeg decoder debug: ffmpeg codec (MPEG-4 Video) stopped
[00000297] main decoder debug: removing module "ffmpeg"
[00000297] main decoder debug: thread 2792344464 joined (input/decoder.c:191)
[00000297] main decoder debug: killing decoder fourcc `XVID', 1 PES in FIFO
[00000297] main decoder debug: cannot find playlist, destroying vout
[00000330] main audio output warning: PTS is out of range (2117664), dropping buffer
[00000330] main audio output warning: PTS is out of range (2093702), dropping buffer
[00000331] main video output debug: removing module "xvideo"
[00000331] main video output debug: thread 2747902864 joined (video_output/video_output.c:461)
[00000329] main decoder debug: removing module "mpeg_audio"
[00000329] main decoder debug: thread 2766789520 joined (input/decoder.c:191)
[00000329] main decoder debug: killing decoder fourcc `mpga', 0 PES in FIFO
[00000364] main private debug: removing module "mpgatofixed32"
[00000365] main private debug: removing module "bandlimited_resampler"
[00000330] pulse audio output debug: Pulse Close
[00000330] main audio output debug: removing module "pulse"
[00000335] main private debug: removing module "float32tos16"
[00000330] main audio output debug: removing module "trivial_mixer"
[00000289] main input debug: thread 2800737168 joined (input/input.c:412)
[00000283] main playlist debug: thread 2843188112 joined (playlist/playlist.c:248)
[00000283] main playlist: stopping playback
[00000283] main playlist debug: deleting playlist item `http://boreas.zshare.net/stream/14c01ddbf87f064ea65cb2f72dbe49b8/1211064000/11824792/1577.avi'
[00000001] main private debug: removing all video outputs
[00000001] main private debug: removing all audio outputs
[00000001] main private debug: removing module "memcpy"
[00000001] main private debug: saving plugins cache file /home/lalit/.vlc/cache/plugins-04041e.dat

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

I don't know if this is relevant but the above output is what I got for 
https://bugzilla.mozilla.org/show_bug.cgi?id=434233
Comment 26 Jakub 'Livio' Rusinek 2008-07-10 12:42:50 PDT
is this actuall for non-openSUSE distros? in openSUSE this bug didn't ever appeared.
Comment 27 timeless 2008-07-11 10:50:01 PDT
the bug was fixed upstream.

note one bug per plugin unless you *work* on the mozilla plug-in host (there are fewer than half a dozen such people).

this bug most *definitely* is a bug in totem, and the *same* bug as bug 378911.

just because one bug is confirmed and another isn't doesn't mean they aren't the same bug.

pascalc: please do *not* "CONFIRM" a plugin bug while it's in the Firefox product.

*** This bug has been marked as a duplicate of bug 378911 ***
Comment 28 timeless 2008-07-11 10:51:08 PDT
nukeador: if you can /actually/ see vlc crashing (your attachment was totem) then please find or file a new bug.
Comment 29 Dave Farrance 2008-07-14 03:45:55 PDT
Created attachment 329422 [details]
Console output in debugging mode
Comment 30 Jakub 'Livio' Rusinek 2008-07-14 03:49:31 PDT
what version of totem?
Comment 31 Dave Farrance 2008-07-14 03:56:47 PDT
totem-mozilla-gstreamer version 2.22.0 is the default browser video plugin in Mandriva 2008.1 (as well as Ubuntu, I understand), so this bug has a high profile.

It causes intermittent video playing failures, and if any of the top three most popular Firefox add-ons (Adblock, Downloadhelper, or NoScript) are installed, then the failure rate goes to 100%.  Confirmed by other Mandriva users:

http://groups.google.co.uk/group/alt.os.linux.mandriva/browse_frm/thread/6d8fe212c105a7e9/852e830cc017ba7b

It's unfortunate that faulty plugins can take down Firefox without any crash report, or indication that the plugin is the problem, because to users it appears that Firefox is flaky.  Apparently a fix was once mooted, bug 156493, and it seems to me that fixing a long standing problem like this would add more to Firefox's credibility than any new features.

Is there any movement in getting a bugfix update of totem released?  Or are they going to leave this in internal subversion for ages?

Attached:  console output with "set -x" uncommented in "firefox" shell script to enable debugging (above).

And incidentally, all the numerous bug reports related to this are either marked as resolved or duplicates, and yet this is still very much an ongoing problem until the Totem fix is released and verified by somebody against Firefox. (bug 378911, bug 412592, bug 425082, bug 423069, bug 434233, bug 424322)
Comment 32 Jakub 'Livio' Rusinek 2008-07-14 04:38:41 PDT
strange. I use GNOME 2.22.0 and Totem 2.22.0 and Firefox 3.0 and have no problems with stability...

the only problem with Totem is playing videos on websites (buffering and sliding progressslider doesn't work well).
Comment 33 timeless 2008-07-15 08:59:30 PDT
this bug tracker is not the proper place for inquiries about totem. please use some other forum. thanks.

Note You need to log in before you can comment on or make changes to this bug.