firefox crashes when totem browser plugins should shown

VERIFIED DUPLICATE of bug 378911

Status

()

Core
Plug-ins
--
critical
VERIFIED DUPLICATE of bug 378911
9 years ago
9 years ago

People

(Reporter: Jakub 'Livio' Rusinek, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008011404 openSUSE/10.3 Minefield/3.0b3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.9b3pre) Gecko/2008011404 openSUSE/10.3 Minefield/3.0b3pre

firefox works great with flash player, but not with native totem's browser plugin.

Reproducible: Always

Actual Results:  
firefox crashes.

Expected Results:  
everything ok.
see also bug 378911 and please provide a breakpad if of that crash.
http://kb.mozillazine.org/Breakpad
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378911
Duplicate of this bug: 412592
> see also bug 378911 and please provide a breakpad if of that crash.
http://kb.mozillazine.org/Breakpad

Matthias, when the application crashes, Reported is not launched and there is no /pending/ folder being created in /<directory>/<where>/<firefox>/<is/<installed>/crashreporter

Is there a bug with breakpad about the Linux version of Firefox? I'd love to be able to provide more information about crashes to help, that's actually why I use nightly builds
It's possible that it failed to catch the crash caused by an external plugin...
my bug #412592 was duped to this one which might be correct (not much details here), but this bug was duped to bug #378911 which is in Unconfirmed state and is definitely a different issue.

I have tried builds to get back to where the regression to my bug was introduced and it was between 2007080204 and 2007080304, that is just after Alpha 7. I do not experience any problem before alpha 7 and bug #378911 is about a problem in alpha 4.
Keywords: regression
I get the crash with Totem and also with VLC Plugin.

Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9b4) Gecko/2008030318 Firefox/3.0b4

Definitely this bug is not duped to bug #378911
reopening since this is not a totem only issue
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

9 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 425082
(Reporter)

Comment 10

9 years ago
What the hell is going on?

Bugs remain open, browser crashes with popular plugins and you're talking to Reuters that Firefox is almost ready...
Same behavior with the latest nightly:

Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.9b5pre) Gecko/2008032604 Minefield/3.0b5pre
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
Flags: blocking1.9?
Are people still crashing with the latest version of the totem player (2.23.0)?
Personally I have yet to see totem (2.20.1) crash here.
The bug also affects to other multimedia plugins, like VLC (Version 0.8.6c), not just Totem.
Nukeador, if you can reproduce this crash then please attach a gdb stack traces or use breakpad to give us something to go on. W/o some help here I doubt we'll get this fixed any time soon.
(Reporter)

Comment 16

9 years ago
Too much dependencies from Rawhide to upgrade Totem, sorry, I can't test it without breaking my system.
-'ing this based on Comment #15.  I know Johnny spent time on this, so any help
here appreciated to reproduce.

Flags: blocking1.9? → blocking1.9-
Created attachment 313356 [details]
Console output after crash

Here it is the only thing I could send, the console output. Breakpad does not launch after crash.

The test was done with beta 5 with a new profile under Ubuntu 7.10

Comment 19

9 years ago
Plugin is built incorrectly (missing proper glue)
Assignee: nobody → chpe
Whiteboard: DUPEME

Updated

9 years ago
Duplicate of this bug: 434233

Updated

9 years ago
Duplicate of this bug: 423069

Updated

9 years ago
Duplicate of this bug: 424322
Maybe the totem plugin should be considered for blacklisting, like QuickTime plug-in version 7.1  in bug 430826?

Comment 24

9 years ago
(In reply to comment #23)
> Maybe the totem plugin should be considered for blacklisting, like QuickTime
> plug-in version 7.1  in bug 430826?
> 
I have seen the crashes on Vista too and there is no totem plugin for windows
VLC 0.8.6e crashes under both Vista and Linux 
but breakpad almost never launches when a plugin crashes 
is there something wrong in the way breakpad is invoked???

Comment 25

9 years ago
[00000331] main video output warning: late picture skipped (650417)
[00000001] main private debug: removing all interfaces
[00000287] main interface debug: thread 2809129872 joined (interface/interface.c:258)
[00000287] main interface debug: removing module "screensaver"
[00000285] main interface debug: thread 2817522576 joined (interface/interface.c:258)
[00000285] main interface debug: removing module "hotkeys"
[00000001] main private debug: removing playlist handler
[00000284] main private debug: thread 3023969168 joined (playlist/playlist.c:247)
[00000289] main input debug: control type=0
[00000289] main input debug: control: stopping input
[00000289] main input debug: closing input
[00000293] avi private debug: free chunk avih
[00000293] avi private debug: free chunk strh
[00000293] avi private debug: free chunk strf
[00000293] avi private debug: free chunk JUNK
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk strh
[00000293] avi private debug: free chunk strf
[00000293] avi private debug: free chunk JUNK
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk LIST
[00000293] avi private debug: free chunk RIFF
[00000293] avi private debug: free chunk LIST
[00000294] main demuxer debug: removing module "avi"
[00000291] main access debug: removing module "access_http"
[00000297] ffmpeg decoder debug: ffmpeg codec (MPEG-4 Video) stopped
[00000297] main decoder debug: removing module "ffmpeg"
[00000297] main decoder debug: thread 2792344464 joined (input/decoder.c:191)
[00000297] main decoder debug: killing decoder fourcc `XVID', 1 PES in FIFO
[00000297] main decoder debug: cannot find playlist, destroying vout
[00000330] main audio output warning: PTS is out of range (2117664), dropping buffer
[00000330] main audio output warning: PTS is out of range (2093702), dropping buffer
[00000331] main video output debug: removing module "xvideo"
[00000331] main video output debug: thread 2747902864 joined (video_output/video_output.c:461)
[00000329] main decoder debug: removing module "mpeg_audio"
[00000329] main decoder debug: thread 2766789520 joined (input/decoder.c:191)
[00000329] main decoder debug: killing decoder fourcc `mpga', 0 PES in FIFO
[00000364] main private debug: removing module "mpgatofixed32"
[00000365] main private debug: removing module "bandlimited_resampler"
[00000330] pulse audio output debug: Pulse Close
[00000330] main audio output debug: removing module "pulse"
[00000335] main private debug: removing module "float32tos16"
[00000330] main audio output debug: removing module "trivial_mixer"
[00000289] main input debug: thread 2800737168 joined (input/input.c:412)
[00000283] main playlist debug: thread 2843188112 joined (playlist/playlist.c:248)
[00000283] main playlist: stopping playback
[00000283] main playlist debug: deleting playlist item `http://boreas.zshare.net/stream/14c01ddbf87f064ea65cb2f72dbe49b8/1211064000/11824792/1577.avi'
[00000001] main private debug: removing all video outputs
[00000001] main private debug: removing all audio outputs
[00000001] main private debug: removing module "memcpy"
[00000001] main private debug: saving plugins cache file /home/lalit/.vlc/cache/plugins-04041e.dat

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_hide: assertion `GTK_IS_WIDGET (widget)' failed

(firefox:16119): Gtk-CRITICAL **: gtk_widget_destroy: assertion `GTK_IS_WIDGET (widget)' failed

I don't know if this is relevant but the above output is what I got for 
https://bugzilla.mozilla.org/show_bug.cgi?id=434233
Assignee: chpe → nobody
(Reporter)

Comment 26

9 years ago
is this actuall for non-openSUSE distros? in openSUSE this bug didn't ever appeared.

Comment 27

9 years ago
the bug was fixed upstream.

note one bug per plugin unless you *work* on the mozilla plug-in host (there are fewer than half a dozen such people).

this bug most *definitely* is a bug in totem, and the *same* bug as bug 378911.

just because one bug is confirmed and another isn't doesn't mean they aren't the same bug.

pascalc: please do *not* "CONFIRM" a plugin bug while it's in the Firefox product.
Status: NEW → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 378911

Comment 28

9 years ago
nukeador: if you can /actually/ see vlc crashing (your attachment was totem) then please find or file a new bug.
Status: RESOLVED → VERIFIED

Comment 29

9 years ago
Created attachment 329422 [details]
Console output in debugging mode
(Reporter)

Comment 30

9 years ago
what version of totem?

Comment 31

9 years ago
totem-mozilla-gstreamer version 2.22.0 is the default browser video plugin in Mandriva 2008.1 (as well as Ubuntu, I understand), so this bug has a high profile.

It causes intermittent video playing failures, and if any of the top three most popular Firefox add-ons (Adblock, Downloadhelper, or NoScript) are installed, then the failure rate goes to 100%.  Confirmed by other Mandriva users:

http://groups.google.co.uk/group/alt.os.linux.mandriva/browse_frm/thread/6d8fe212c105a7e9/852e830cc017ba7b

It's unfortunate that faulty plugins can take down Firefox without any crash report, or indication that the plugin is the problem, because to users it appears that Firefox is flaky.  Apparently a fix was once mooted, bug 156493, and it seems to me that fixing a long standing problem like this would add more to Firefox's credibility than any new features.

Is there any movement in getting a bugfix update of totem released?  Or are they going to leave this in internal subversion for ages?

Attached:  console output with "set -x" uncommented in "firefox" shell script to enable debugging (above).

And incidentally, all the numerous bug reports related to this are either marked as resolved or duplicates, and yet this is still very much an ongoing problem until the Totem fix is released and verified by somebody against Firefox. (bug 378911, bug 412592, bug 425082, bug 423069, bug 434233, bug 424322)
(Reporter)

Comment 32

9 years ago
strange. I use GNOME 2.22.0 and Totem 2.22.0 and Firefox 3.0 and have no problems with stability...

the only problem with Totem is playing videos on websites (buffering and sliding progressslider doesn't work well).

Comment 33

9 years ago
this bug tracker is not the proper place for inquiries about totem. please use some other forum. thanks.
You need to log in before you can comment on or make changes to this bug.