Closed Bug 412352 Opened 14 years ago Closed 14 years ago

Inconsistent layout with <input type="file">, position:absolute

Categories

(Core :: Layout: Form Controls, defect)

x86
macOS
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jruderman, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: testcase)

Attachments

(4 files)

Testcase 1 (identical to layout/forms/crashtests/386554-1.html) demonstrates a subtle difference in dynamic vs. static rendering: the anti-aliasing pixels are cut off in the testcase but not in the reference.

Testcase 2 makes the problem more clear using a border: the width of the div is different by several pixels.
Attached file testcase 1
Attached file reference 1
Attached file testcase 2
Attached file reference 2
> identical to layout/forms/crashtests/386554-1.html

Oops, not quite identical.  I removed a "top: 100%".
Is this a regression?  Or Mac-only?  I can't reproduce in a 2007-11-27-02 Seamonkey build on Linux.
I can reproduce with testcase 2 / reference 2 in a 2007-11-11 Firefox build on Mac.  So I guess it's Mac-only.
Does the problem go away if you set -moz-appearance:none on the file input?
Setting "-moz-appearance: none" has no effect on the appearance of file upload controls and does not make this bug go away.
Yeah, I can reproduce on Mac but definitely not on Linux.  Any incremental reflow (e.g. opening the findbar) makes the testcase look like the reference.
So... the frame geometry per se is the same between the two testcases.  The overflow areas, however, are different.  In particular, the overflow rect width of the button is different by 5px or so.

I'm not quite sure why there are these random overflow rects all over this testcase, to be honest (e.g., why does the text input have 4px horizontal overflow to the left?).  But that 5px difference in the overflow rect is what causes the different rendering here.

roc, any idea what's up?
Nope. I don't think this is going to block 1.9 though...
WFM, Mac trunk debug.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Flags: in-testsuite?
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.