New location bar style requires GTK 2.12

RESOLVED FIXED in mozilla1.9beta3

Status

()

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: ispence, Assigned: twanno)

Tracking

Trunk
mozilla1.9beta3
x86
Linux
Points:
---
Bug Flags:
blocking1.9 ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
The "arrow-scaling" style attribute used to fix bug 405210 wasn't added until 2.12

While Teune van Steeg correctly points out that this attribute is not listed as new in 2.12, I would like to point out the differences between the following pages.

http://library.gnome.org/devel/gtk/2.10/GtkArrow.html
http://library.gnome.org/devel/gtk/2.12/GtkArrow.html

More specifically, the lack of "arrow-scaling"

The following URL shows the checkin for arrow-scaling, done September 19, 2006, which is 2 weeks after the release of 2.10.3
http://www.ohloh.net/projects/4293/contributors/2660/commits/5616553


Anyhoo, the documentation states that the default value is 0.7, so that should probably be used for users of gtk 2.10
(Reporter)

Updated

11 years ago
Summary: New location bar style required GTK 2.12 → New location bar style requires GTK 2.12
(Assignee)

Comment 1

11 years ago
OK, thanks for filing this bug. I will remove it then and just use 0.7, because I also expect this piece of code to have caused the Lk regression on fxdbug-linux-tbox. Local testing seems to indicate that.
Depends on: 405210
(Assignee)

Comment 2

11 years ago
Created attachment 297204 [details] [diff] [review]
Use the default value for arrow scaling
Assignee: nobody → twanno
Status: NEW → ASSIGNED
Attachment #297204 - Flags: superreview?(roc)
Attachment #297204 - Flags: review?(roc)
Comment on attachment 297204 [details] [diff] [review]
Use the default value for arrow scaling

How did this cause a leak? Gtk bug?
Attachment #297204 - Flags: superreview?(roc)
Attachment #297204 - Flags: superreview+
Attachment #297204 - Flags: review?(roc)
Attachment #297204 - Flags: review+
Flags: blocking1.9?
Attachment #297204 - Flags: approval1.9?
(Assignee)

Comment 4

11 years ago
(In reply to comment #3)
> (From update of attachment 297204 [details] [diff] [review])
> How did this cause a leak? Gtk bug?
> 

If this is indeed causing a leak, of which I'll only be certain when the Lk values go down again, then I'm pretty sure it must be a GTK bug. I don't know what else it could be.
(Assignee)

Comment 5

11 years ago
Clean numbers of local Lk values
before above patch (3x):
5838679
5802234 (<- this is why I'm not sure)
5845568

after above patch (3x):
5580941 (must have been different circumstances here)
5803109
5806426

second test before patch (with some other changes):
5802299 (<- again this why I'm not sure)
5845192
5845131

second test after patch (with some other other changes):
5802678
5800617

Updated

11 years ago
Attachment #297204 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in widget/src/gtk2/gtk2drawing.c;
/cvsroot/mozilla/widget/src/gtk2/gtk2drawing.c,v  <--  gtk2drawing.c
new revision: 1.68; previous revision: 1.67
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M11
You need to log in before you can comment on or make changes to this bug.