link to add (edit) product / components should be possible from edit bug screen

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
11 years ago
9 years ago

People

(Reporter: bigstijn, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 1.0.3705; InfoPath.1; .NET CLR 2.0.50727)
Build Identifier: Bugzilla 3.0

When you're having editcomponents rights , and you're on the edit bug screen for a particular product, you should be able to add (edit) milestones, versions, .. almost directly.

This can be done by adding a link to editproducts?product=xxx , and even editmilestones, ..



Reproducible: Always

Steps to Reproduce:
1.Start to enter a new bug for a certain product
2.Add a new component (like target milestone)
   2b. Click on "products"
   2b. Find the correct classification and click on it (if classification is used)
   2c. Find the correct product, and click on it 
3.
Actual Results:  
You have to click yourself through some (possible) long pages.

Expected Results:  
If you could 'directly' add a new component (milestone) from the editbugs screen, this would be very useful.


Possible solutions:

- add a direct link to "add new component", link behind a symbol (like [+])
- add a direct link to "edit this product", link add the bottom of the "Details pane"

Comment 1

11 years ago
in this bugzilla, we have Format for printing, xml, and clone this bug.

Having an "edit items from this page" (better term needed) link there would be kind of neat.

I think it'd probably be best if it basically generated a page similar to format for printing, but where each value is a link to edit it, and each label is a link to edit the category.

so for this bug, you'd have:
/Status/ = link to edit status workflows
Unconfirmed = link for edit canconfirm ?
Keywords = edit keywords
since there are no keywords, there will be no links to editing a specific keyword
Votes = link to edit votes rules for product Bugzilla
Product = editproducts
Bugzilla = edit bugzilla product
Component = editcomponents for bugzilla product
Creating/Changing Bugs = editcomponent for Bugzilla: Creating/Changing Bugs 
Version = editvresions for Bugzilla product
Hardware/OS = Edit field values
All/All = Edit that specific field value
Assigned To/QA Contact = edit components for Bugzilla
assignee/qa = edit component for Bugzilla: Creating/Changing Bugs 
Targetmilestone = edit milestones for bugzilla
--- = edit bugzilla --- milestone
flags = edit flags (filter for product bugzilla, sorting things that specifically select creating/changing bugs to the top)
approval = edit approval flag (etc)

no edit attachment flags because there are no such flags.

Comment 2

11 years ago
You don't edit product attributes every day. Having such links in show_bug.cgi seems inappropriate to me. show_bug.cgi already has many links in it; I wouldn't want to see new ones, especially when you know that editing a bug has nothing to do with editing product attributes. I would tend to close this bug as WONTFIX.

Comment 3

11 years ago
it's only one link, just like format for printing. it's basically an entirely different template which prefills links by bugid.

and it's actually very close to how normal component changers do work.

someone says something like "why can't i add flag X to bug Y"
or "why can't i set tm for bug Y to Z"

the common thread is that you're actually on a bug Y. Being able to click one link to go from the bug to being able to click any field in the bug to edit it isn't unreasonable.
(Reporter)

Comment 4

11 years ago
The solution of comment 1 is indeed a good solution, finding the balance between an easy access and a good layout.


Certainly if you have quite some products and classifications, this can help.

About the further implementation, (only) if it's possible as quick win, maybe we could allow people after they have added fields, to refresh the bug entry page, keeping the current content.  We could use the bug entry template functionality for this.

Comment 5

9 years ago
wontfix per comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

9 years ago
Well, if plenty of links is a problem (as stated by comment 2), maybe just 1 link : edit this product ?

Milestones en Version are added often, e.g. in a "change control board".
You need to log in before you can comment on or make changes to this bug.