The default bug view has changed. See this FAQ.

ability to edit feed properties (title/URL)

RESOLVED FIXED in Thunderbird 13.0

Status

MailNews Core
Feed Reader
--
enhancement
RESOLVED FIXED
9 years ago
5 years ago

People

(Reporter: Gavin Lambert, Unassigned)

Tracking

unspecified
Thunderbird 13.0

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 716706])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 2.0.0.9 (20071031)

When I go to the RSS Subscriptions window, I expect to be able to edit the feed title and URL.  TB lets me do neither.  (Not being able to edit the URL is a fatal flaw.)

Reproducible: Always

Steps to Reproduce:
1. Subscribe to the feed.
2. Select the feed.
3. Click Edit.
4. Notice how the URL field is read-only and there is no field for the title (nor is there a rename option in the Subscription window itself).


Expected Results:  
Both the URL and the title should be editable.  Especially the URL.

Comment 1

9 years ago
Confirming RFE. (This would be the rfe part of bug 297815 comment 15.)
Severity: major → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: PC → All
Summary: Cannot edit feed properties → ability to edit feed properties (title/URL)
(Reporter)

Comment 2

9 years ago
Yes, it does look like what that comment was suggesting.  Did such an issue ever get filed?  I did do a search before posting this and I couldn't find anything...

(And incidentally, on Windows that field does not look disabled.  Had it looked disabled then I would have filed this as an RFE and not a bug.)

Feed support in Thunderbird seems to be very much a third-class citizen at the moment; there's lots of usability failures.  (There's another thing in particular about the Subscribe window that really annoys me, but I guess that should probably be filed as a separate RFE.)

Comment 3

9 years ago
Yeah, didn't find any other bugs filed for this issue. 

> And incidentally, on Windows that field does not look disabled. 

It doesn't? Is that a vista-only issue?
(Reporter)

Comment 4

9 years ago
I'm not sure.  I don't have an XP system to test it on at the moment.
It shouldn't look disabled, it should look read-only, like data:text/html,<input readonly value="foo"> does in Firefox. Of course, nobody ever sees read-only inputs, so that appearance isn't at all familiar, but disabled means you can't copy-paste.
(Reporter)

Comment 6

9 years ago
Ok, well it does look and behave like the HTML readonly field.  However the appearance is still identical to the non-readonly field -- the only difference is behavioral; if you click in the readonly field you don't get a carat (but you can still select text) and typing is ignored.  Some kind of grayed-out background would have been nicer.

But anyway, that's a side issue.  The point of this bug/RFE is that I don't want it to be readonly in the first place -- that causes problems when feed URLs change (which has happened a lot to me recently).
Duplicate of this bug: 487422

Updated

8 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Duplicate of this bug: 530500

Updated

7 years ago
Duplicate of this bug: 532580

Comment 10

5 years ago
feed titles/urls can now be updated in the Subscribe dialog, per bug 716706.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Depends on: 716706
Whiteboard: [fixed by bug 716706]
Target Milestone: --- → Thunderbird 13.0
You need to log in before you can comment on or make changes to this bug.