Text formatting lost when pasting from a non-html application, RTF required.

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
11 years ago
9 years ago

People

(Reporter: info, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-05-12)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: version 2.0.0.9 (20071031)

When pasting text with formatting, copied from any non-HTML application into Thunderbird (2.0.0.9), the formatting (such as bold, italic, underline, text size) isn't retained and it comes out as plain text. 
Applications we’ve tested this with are WordPerfect 12 & 8, Word 2000 and Wordpad under Windows XP.
After looking at the formats stored in the clipboard, using the freeware application CFList, I notice that WP, MS Word and Wordpad all have Rich Text Format as one of the formats used.
Cflist shows that text copied from Thunderbird is created in the clipboard with a number of HTML based formats and ‘Plain text’ but not rtf.
Our conclusion is that Thunderbird does not support rich text format, which is surprising as rtf is probably the most commonly supported standard for text with basic formatting.
If Thunderbird could interpret Rich Text Format from the clipboard and create it in the clipboard, it would allow formatted text to be copied and pasted between Thunderbird and most text handling applications.
This could solve some other bugs listed such as 347821, 239817, 312739, 405775.
We note that copying formatted text between Word and Thunderbird is hit or miss because apparently Word creates a non-standard HTML format in the clipboard, which is currently the highest level format created by MS Word recognised by Thunderbird. MS Word 2000 creates a rtf copy in the clipboard with a higher level than HTML and so this would be used in preference to the HTML copy if it was supported by Thunderbird.
As a further enhancement a ‘Paste Special’ option & dialog could be created, to choose between, for example, Plain text, RTF and HTML formats and the selection of a default choice for the paste shortcuts.


Reproducible: Always

Steps to Reproduce:
1.Copy text with formatting (bold/italic etc.) from WordPerfect, Wordpad or another non-html application.
2.Start a new HTML e-mail and paste into it.

Actual Results:  
Text appears as plain text, no formatting retained.

Expected Results:  
Expected the formatting (bold, italic, etc) to copy with the text.
Please prefix bug numbers with the word "bug" to get them autolinked, like bug 347821, bug 239817, bug 312739, bug 405775.

Comment 2

10 years ago
Same as bug 428096?
Gary maybe your issue can be a duplicate of one of bugs listed in comment #1 and comment #2?
Whiteboard: closeme 2010-05-12
Version: unspecified → 2.0
RESOLVED INCOMPLETE due to lack of response to previous comment. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.