Unable to enter a mail-adress like irgendwas@irgendwas.de after send to irgendwas@irgendwas.de.blah.de

RESOLVED DUPLICATE of bug 533109

Status

RESOLVED DUPLICATE of bug 533109
11 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: Version 2.0.0.9 (20071031)

If i send a Mail to irgendwas@irgendwas.de.blah.de and than to irgendwas@irgendwas.de rewrite thunderbirds autocomplete feature the adress always to irgendwas@irgendwas.de.blah.de without chance to change to the right adress.

This was a reported in <http://www.heise.de/open/news/foren/S-Ist-sowieso-Schrott/forum-130422/msg-14242673/read/>


Reproducible: Always

Steps to Reproduce:
1.Write a Mail to irgendwas@irgendwas.de.blah.de and than
2.write a Mail to irgendwas@irgendwas.de 
(Attention! The domain is blah.de is valid)
Actual Results:  
can't enter the adress irgendwas@irgendwas.de because the autocomplete funtion change the email-adress always to irgendwas@irgendwas.de.blah.de

Expected Results:  
send a mail to: irgendwas@irgendwas.de
Hardly a typical use case;) If you really need it I think it should work if you open the url mailto:irgendwas@irgendwas.de from a browser
Following is test result with Tb 2.0.0.9(MS Win-XP).
(Case-1) None of two mail addresses is registered to Address Book.
         Both could be set in To: field.
         (Deletion of '.blah.de' works even when auto-completed.)
(Case-2) Only irgendwas@irgendwas.de.blah.de is registered to Address Book.
         Problem was re-produced.
(Case-3) Both mail addresses are registered to Address Book.
         Both mail addresses were listed as candidates,
         and any of them could be chosen or typed.

Workaround: Add irgendwas@irgendwas.de also in your Address Book. 

Comment 3

9 years ago
similar behaviour in TB 2.0.0.22 (WXP):

"John Doe <jd@example.com>" is in the adress book.

It is impossible to have only "jd@example.com" in the address line without editing the address book. TB autocompletes to show the full name, wich I didn't want do disclose with the respective mail.

Comment 4

9 years ago
Fast Workaround: (works in TB3.0)

type address followed by ",", then hit enter. autocompletion is interrupted by delimiting ","

Updated

9 years ago
Duplicate of this bug: 566830

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 533109
You need to log in before you can comment on or make changes to this bug.