1password disappears from toolbar with this build

VERIFIED INVALID

Status

VERIFIED INVALID
11 years ago
11 years ago

People

(Reporter: coldrick, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.12pre) Gecko/20080116 Camino/1.6b1pre (like Firefox/2.0.0.12pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.12pre) Gecko/20080116 Camino/1.6b1pre (like Firefox/2.0.0.12pre)

For a number of builds now (couple of weeks worth, at least), my 1Password button no lionger appears in the toolbar. I return to an earlier version and it returns.

Reproducible: Always

Steps to Reproduce:
1. Install current 1Password
2. Install current build
3. No button!


Expected Results:  
displaye dthe button
Camino has no control over 1passwd; it's a third-party utility.  You should contact the developers of 1passwd about this problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
The point is that 1Password works with Firefox, Safari, and earlier builds (eg 2008010701 (2.0a1pre)) of Camino. So I'd suggest that you folks have done something to break it in recent builds. I will indeed contact the 1Password folks, but my guess is that it's a problem with Camino.

Regards,
David

Comment 3

11 years ago
(In reply to comment #2)
> So I'd suggest that you folks have done something to break it in recent
> builds. I will indeed contact the 1Password folks, but my guess is that it's
> a problem with Camino.

We probably did (unintentionally), but that's irrelevant; 1Password integrates with Camino through a series of completely unsupported runtime hacks to Camino internals. Absolutely nothing about what they are doing to run in Camino is based on a stable API or otherwise supported. The only way we could possibly guarantee that we would never break 1Password (or other unsupported Camino add-ons) is, quite literally, never to change anything about Camino ever again, because we have no idea what in Camino's code they are relying on being the same.

By definition, 1Password breakage in any new version of Camino is a problem with 1Password, not Camino (in the same way that when, say, a new iPod comes out with a different form factor, iPod case makers have to make new cases--it's not a design flaw in the new iPod). The 1Password developers understand this, and have chosen to accept the ongoing maintenance that such an approach requires.

If you are using it with Camino nightly builds, it's likely that you'll run into issues again in the future, and you'll have to continue to report them to the 1Password developers so that they can release new, compatible versions of their software.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.